3

I installed Ubuntu 17.10 with Gnome Shell some days ago.

My dash finds all my applications (so it works just fine), but it only finds files and folders located directly in my home folder. It doesn't find files/folders located in subfolders of the home directory or recent files.

For example, imagine that in my home directory I have folders

  • foo1
  • foo2

and files

  • bar1.odt
  • bar2.odt

and that folder foo1 includes file bar3.odt.

Also imagine that I just opened (through Nautilus and then OpenOffice) a file bar4.odt located in folder foo2.

If I type bar3 (file in a subfolder) or bar4 (recent file), the dash returns "No result" (I'm translating from Italian "Nessun risultato").

If I type foo1 or bar1, it returns the correct results because they are directly located in my home folder.

I reinstalled install unity-lens-files and tried the solution by jnv (#10) in Unity "Files & Folders" lens can't find anything:

zeitgeist-daemon --quit
rm -rvf ~/.local/share/zeitgeist/fts.index/
zeitgeist-daemon --replace

...to no avail.

When I do zeitgeist-daemon --replace, I receive this warning message:

$ zeitgeist-daemon --replace
[16:48:00.914102 WARNING] zeitgeist-daemon.vala:127: Unable to parse version info!
[16:48:01.355342 WARNING] zeitgeist-daemon.vala:127: Unable to parse version info!

** (zeitgeist-datahub:3580): WARNING **: zeitgeist-datahub.vala:227: Unable to get name "org.gnome.zeitgeist.datahub" on the bus!

In /usr/share/unity/client-scopes.json the line about the unity-lens-files reads as follows:

"unity-lens-files": ["files-local.scope"],

In dconf / desktop / unity / lenses / files, the use-locate option is set to ON.

In settings / search, the File option is ON.

  • I edited my own question as I found out that my Gnome Shell comes with Gnome Shell, not Unity. So my question stays the same, but it regards Gnome Shell. – Ilbuonme Nov 6 '17 at 19:30
  • For what it's worth, Zeitgeist emits the same error messages on my computer, but they seem not to be critical because it's still working. As mentioned in the answers, Gnome Shell is using Tracker rather than Zeitgeist for file search. – Ian Mackinnon Feb 1 '18 at 7:54
  • A quick way to ensure that Zeitgeist is working is this command sqlite3 ~/.local/share/zeitgeist/activity.sqlite 'select timestamp from event order by timestamp desc limit 1'. The value should increase every time you open or close a file. – Ian Mackinnon Feb 1 '18 at 7:56
  • I think zeitgeist is the wrong tool, since it doesn't index but journals activity. You need an indexer, see answer below. – Robert Riedl Feb 3 '18 at 17:14
4
+50

GNOME shell only indexes some files in your home directory or in the "default" folders.

However, for 17.10, a decision was made not to automatically install the necessary tools to modify the index, namely tracker. This is due some concerns that it might be too invasive and/or too taxing to CPU and io.(*)

sudo apt-get install tracker

If you have installed trackeryou can edit the search via the Settings menu:

  1. Go to Settings
  2. Navigate to Search
  3. Make sure you have Files turned on and maybe disable the other searches you don't like (i.e. Software Center, Calendar, etc)
  4. Click the little gear (⚙️) button at the bottom to open the menu Search options menu with tracker
  5. Then navigate to Other and click the plus (+) symbol to add other search-paths add custom search path with plus
  6. After you have closed the Settings panels, you can either log-out and back in or start the index manually with

tracker daemon -s

You can then check its progress with

tracker status

and get an output similar to this:

Currently indexed: 3556 files, 174 folders
Remaining space on database partition: 170.5 GB (69.29%)
All data miners are idle, indexing complete

(*) Personally, I've not seen any negativ side effects. In fact, on my modern SSD the index process is finished in seconds for ~3500 files with 54GB in total.

  • Thank you so much! This solved the issue for me. I'd also like to thank Ian MacKinnon for the bounty. – Ilbuonme Feb 4 '18 at 20:52
1

GNOME shell by default indexes files which are in your home directory or in the "default" folders (Documents, Downloads, Music, Pictures and Videos).

But you can manually add a folder to be included for searching. To do that follow the steps below.

  1. Open Settings.
  2. Navigate to Search option. Make sure "Files" is turned on
    enter image description here
  3. Click on the cogwheel (⚙️) at the bottom. A window should pop up.
  4. Go to the "Other" tab.
  5. Click on the + icon and add the folder you want to be included for searching.
    enter image description here
  6. Reboot.

It seems tracker is no longer installed by default in Ubuntu 17.10 (see Robert Riedl's answer), you'll have to install tracker manually first.

  • This was also useful: you can customize the indexed folders. Thank you. – Ilbuonme Feb 5 '18 at 8:21
  • In Ubuntu 18.10, you cannot anymore access settings to change the scope – vanadium Apr 4 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.