0

I'm trying to install Ubuntu Gnome 16.04.03 on the latest (as of Q4 2017) GS63VR 7RG Stealth Pro (with GTX 1070 MQ) and the install gets stuck on 'almost finished copying files...'

I've

  • tried with the BIOS the laptop came with, and updated to current (official) latest
  • disabled secure boot from bios
  • set TMP20 UEFI spec to TGC 2, TGC, 1.2, and disabled completely
  • with and without internet connection
  • with and without doing updates during install
  • with and without third part software and drivers during install
  • tried using automatic partitioning, and manual (200GB for root /, 10GB for swap)
  • tried installing on the 512GB ssd (alongside windows) or on the 1TB hdd.
  • tried 16.04.3 and 17.04 (details on this below)
  • checked the md5 of the ISOs (both 16.04.3 and 17.04) and they are both ok.
  • I've re-downloaded, and re-flashed to USB sticks multiple times (with Ubuntu Startup Disk Creator)

I've tried all combinations of above, dozens of attempts, and immediately after selecting region, username etc I get the dialog "almost finished copying files" and it always gets stuck (I've waited hours, to no avail).

I have experience installing linux (including on tricky devices like surfacepro, razerblade etc years ago when they first came out), so I'm not a complete noob - but I'm by no means a pro. and this has just got me completely stuck. I can't get past the copying files phase.

Google is full of 'installer stuck on copying files', but they all seem to suggest one or more of the things I mention above. I'm beginning to suspect whether this is a hardware compatibility issue, but this user seems to have at least gotten past the installer, so maybe it's a hardware fault?

Also worth noting:

  • I tried 17.04 too (though I'd prefer 16.04), but that doesn't even boot from live disk. "[error: 6.180767] mmc0: Unknown controller version (3). You may experience problems."
  • I found this guide, https://forum-en.msi.com/index.php?topic=292505.0 but that's for a slightly different (and older) model. Also I can't even install, let alone have problems after installation
  • when I run gparted from the live disk, I get a warning / error "The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes"
  • When I boot from live disk (16.04), it doesn't seem perfect. e.g. if I select 'reboot' or 'shutdown', it just hangs and nothing happens
0

Did you try also Ubuntu 17.10? It has newer kernel (4.13.0). I was able to install it, without issues on my MSI GS63VR 6RF. I can try to help you.

Gabriel

  • thx for the tip, problem turned out to be the make of the USB sticks I tried! – memo Oct 26 '17 at 10:17
0

I had tried 3 different USB sticks, in case there was something wrong with the stick, but all of the same brand / model (Kingston Technology 32 GB Data Traveler USB Flash Drive with Metal Casing). And it failed in the same way each time.

Now I tried a different stick (a much older, 2GB crappy and very slow USB stick) with the same ISO (16.04.3), and it worked! So the problem was the brand / model of the USB stick :/

So far all running fine.

Update: I think both sticks are USB 2.0, the USB stick which worked is a lexar 2GB. Benchmark showed avg read speed 11.1MB/s and avg write speed 3.6MB/s. For the Kingston's that didn't work, avg read is 25.9MB/s and avg write is 6.8MB/s (and inside is black, not blue)

  • When you say older do you mean USB 2? – WinEunuuchs2Unix Oct 26 '17 at 11:32
  • good question, they're both USB 2, but the one that worked is much older, smaller and slower. I've updated my answer with details – memo Oct 26 '17 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.