10

I'd like to apologize in advance if this is not ubuntu related issue, but I did not manage to find any other topics regarding my problem.

What's going on: I'd like to start using screen recording software called Open Broadcaster (OBS). But I ran into an issue when the recorded screen is black and only the cursor is visible.

I've found many similar topics about this problem, but most of them were related to Game Capturing mode. I can not get this done with Screen Capture mode.

The interesting thing is that Window Capturing mode (recording specific application windows - browser, editor, etc.) works. But that does not meet my needs.

Unfortunately I did not play around with this before my recent dist upgrade to Ubuntu 17.10 so I can not confirm if this was a problem even before upgrade or if it's brand new thing. The fact is, that I did not manage to find any similar issues which regards, once again, Screen Capture mode.

Any advices or tips are strongly appreciate.

Thanks a lot!

marked as duplicate by pomsky, karel, Eric Carvalho, Zanna, Fabby Mar 17 '18 at 20:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

11

Ubuntu 17.10 runs on wayland as display manager and most software like OBS are not yet updated for it.

To make OBS work log out and beside "Sign in" button you will see a small cogwheel. click on it and choose "Ubuntu on Xorg" or "Gnome on Xorg" and you're good to go, OBS should work on that, but this reverts you to using X as display manager.

  • Thank you, it solved the problem. I was suspecting this to be the issue. Anyways, I am not familiar with all these display managers things. Is there any significant difference between those options? Should I prefer any of those? – Dan Charousek Oct 27 '17 at 11:34
  • If you want to record with OBS you have actually no choice to be honest, wayland is newer and has some security features, but as you saw some software is actually simply not ready for it yet. I'm on X11 for that reason too. – Videonauth Oct 27 '17 at 11:38
  • Thanks for the answer. I had the same issues with SimpleScreenRecorder, as well as other tools such as web meeting tools (GotoMeeting, etc. with screensharing features). Switching to Xorg helped. – Mathias Conradt Jan 22 '18 at 14:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.