I had this issue since I've bought a new laptop (HP Pavilion 15 Gaming) with nvidia 960M. No matter which driver I use, properitary or nouveau with or without intel graphics turned on my machine won't complete reboot cycle or shutdown, it will just hang. This is with quiet splash turned on in grub config.

Without quiet splash it reboots and shuts down without a problem. I have tried numerous solutions with acpi options that I found on this site and others and none of it worked. The only thing that works is to remove quiet splash.

Does anyone have any insight why is this happening or how I can resolve this issue (remember all the acpi, acpi_* combinations failed for me) because it's been like this since day 1 from 17.04 onward.


I had the same problem with a Lenovo E470 with NVIDIA 940MX.

In my case removing just the "splash" parameter solved the problem.

  • But I want the splash. I know how to remove quite splash, that not the solution I was looking for. I have resolved it in meantime, weirdly update initramfs worked for some reason. – Von Goofy Jan 20 '18 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.