8

Updated from 17.04 to 17.10. If I create a new Nautilus window from the desktop by pressing Ctrl+N, I get the following message:

Sorry, could not display all the contents of "x-nautilus-desktop:///": The specified location is not supported.

Do I need x-nautilus-desktop bookmark and how can I get it working under Ubuntu 17.10 and Wayland?

5

I had the same problem with fresh install of 17.10 when opening a new window of Nautilus using CTRL+N shortcut. I avoid that message creating an additional shortcut for Nautilus:

  1. Go to keyboard settings, you should see the list of keyboard shortcuts.
  2. Click on the "+" button at the bottom of that list to create a new shortcut.
  3. Create a new shortcut filling the params asked:

    Name = Open nautilus (or any other name you want)

    Command = nautilus (like when you open nautilus from terminal)

    Shortcut = Press the "Set Shortcut..." button and press **CTRL+M** (or any other combination you want).

After setting the new shortcut for CTRL+M, close keyboard settings and the new shortcut will open nautilus without the "x-nautilus-desktop:///" error pointing to your home folder.

Hope this helps.

EDIT (WARNING): The solution described helps to avoid the error mentioned, but not to solve the error itself. If you try to overwrite the CTRL+N shortcut that will overwrite the shortcut for any other app. That is, for example, after CTRL+N overwriting in Google Chrome will open a new Nautilus window and not a new Chrome window. In my case, I set new Nautilus window to CTRL+M. This does not solve the "x-nautilus-desktop:///" error itself, but it's an alternative solution. If you set a new shortcut for Nautilus new window as CTRL+M, if you use CTRL+N you still get the error mentioned.

ADDITIONAL INFORMATION:

You can set the command param for opening nautilus in any directory you want, for example: Command = nautilus ~/Downloads will open nautilus in Downloads directory when CTRL+M is shortcut is used.

BUG REPORTED: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1710931

  • This doesn't seem to fix the problem at all, just shift it to another key. The bug has been marked obsolete, so a fix seems unlikely – scruss Mar 24 '18 at 14:22
  • 1
    Thank you! I've been ignoring this annoying message for months now. This solved the issue. – wout Oct 3 '18 at 18:03
  • 1
    @wout Same thing for me -- I've been ignoring this message for a few months since getting a new computer. It would be nice to get rid of the error, but long-term switching to ctrl-M is an effective alternative. – 6005 Jan 22 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.