0

I have a Lenovo legion notebook with Nvidia 1050Ti GPU along with Intel graphics. I installed Ubuntu 17.0 in june and painstakingly installed Nvidia drivers 375.22 and Cuda etc. This morning after an upgrade to Ubuntu 17.10, nvidia commands like nvidia-smi and nvidia-settings stopped working. I was getting errors that libnvidia.so was missing. I checked the Nvidia driver version with lspci -k and found it to be 384.xx. In order to fix this issue, I made the mistake of running the old driver installer (ver 375.22) and rebooting.

Now I am not even able to reach the login screen. I tried to restore /etc/X11/xorg.conffrom an older version by booting into recovery, with no luck. Is there a way to fix this (atleast be able to run the system using Intel graphics) without doing a fresh install?

  • 2
    You should be able to select your older kernel (with driver) at the Grub prompt early during boot. DON'T try to mix different drivers with different kernels - it won't work, as you discovered. 'Drivers' are really just another name for kernel modules, must be compiled for their kernel, and won't work with others. – user535733 Oct 24 '17 at 4:20
1

I had the same problem with you. And I solved it by

sudo apt-get purge nvidia*

in the recovery mode.

Honestly, it is not the best way to solve the issue, but it seems to be the only way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.