0

I recently got an Nvidia card, after long debating I convinced myself that I earned a little gaming - tho I only used the machine for webdev. so far I have no experience with gcards and ubuntu.

I installed the driver, or at least I tried. I got some problem with the nouveau kernel - so whatever stumbled upon this thread

How to disable Nouveau kernel driver

Did whats posted on the accepted answer and now the pc won´t start.

I got 2 Kernels in the Advanced Menu (4.10.0-35 and 4.10.0-37) but in the root bash I also do not get any eth device to work, so no way of sudo apt-get update / upgrade.

Tomorrow I can get an USB Stick with 17.04 Live on it, any quick way to fix that with the Live Image? Recovery? Will it keep my files - I got an Backup, but not from my databases. So it would be nice to fix it.

Is there a log where I can figure out where the problem is?

  • You said that your PC won't boot. What do you mean? Are you having a login-loop (putting your password and instead of loading the desktop it's asking for password entry again)? – George Mathioudakis Oct 23 '17 at 21:05
  • Sorry, I shoul´ve been more specific. It stops when loading "Starting user manager with UID ..." on the boot process – Isengo Oct 23 '17 at 21:11
  • Please, if you can be more specific (as you said), edit your post and add more info. Do you have access to a root shell? Can you use apt-get update/upgrade/dist-upgrade? Do you have internet access? Can you boot on recovery mode kernel through "Advanced options"? – George Mathioudakis Oct 23 '17 at 21:24
  • I answered 2/3 already in my initial post. No internet / I can access the root shell and I can use the Advanced options. – Isengo Oct 23 '17 at 21:30
  • If you're on Wi-Fi, make a connection between your Computer and Router/Modem device via ethernet. Then, follow this guide in order to gain internet access via recovery-mode. Many users have solved the "Stuck on 'Starting user manager with UID'" problem by using apt-get update/upgrade/dist-upgrade. You can give it a try. – George Mathioudakis Oct 23 '17 at 21:45
-1

Had the same issue.

There is a way to boot with Ubuntu "live CD" or "Live USB stick", then select "Try Ubuntu".

When in, you can mount your "broken" system in terminal with:

sudo mount /dev/sda2 /mnt

sudo mount --bind /dev /mnt/dev

sudo mount --bind /proc /mnt/proc

sudo mount --bind /sys /mnt/sys

sudo chroot /mnt

now you can delete all the nvidia stuff and revert the blacklisting....

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.