1

I have dual boot on my laptop with Windows 10 and Ubuntu installed.

I've shrunk the Ubuntu /home partition using Gparted (with live USB). The /home partition was the last partition on the disk (/dev/sda8) and then I've created a new partition from the available space in Windows 10 (now /dev/sda9).

I can successfully boot into Windows 10, but I could only boot into Ubuntu once. Now I am getting a mount /boot/efi problem. But the strange thing is, if I boot into recovery and do anything in there (like delete broken packages), I can boot into Ubuntu normaly from there, but without graphics drivers enabled (if I understand correctly).

This is the output of blkid:

/dev/sda1: LABEL="Recovery" UUID="B6A4BF3CA4BEFDC5" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ffdc36db-cfb8-4fd1-9332-3ed503822b68"
/dev/sda2: UUID="2AC0-616C" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="51f3571e-2f45-4341-956d-dce2730a1cb3"
/dev/sda4: UUID="542CEA772CEA5390" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="326c35cf-e400-4a9e-9cb5-037d095693c8"
/dev/sda5: UUID="708E254E8E250DE2" TYPE="ntfs" PARTUUID="c9b8ef8c-404d-4fa3-a042-9546a666cb1e"
/dev/sda6: UUID="c86e443e-6f16-41ed-ab74-269861d79e05" TYPE="ext4" PARTUUID="e3987e40-45a9-4b87-ba24-4fd1ba35048c"
/dev/sda7: UUID="985ef0a6-6275-4423-ba18-c8919463410c" TYPE="swap" PARTUUID="d1994c9e-7bec-4db6-a6c2-5023ba0ce54a"
/dev/sda8: UUID="5860e919-7209-4cd2-8576-619df3114ab2" TYPE="ext4" PARTUUID="65549518-7248-4804-aea8-f6325c4a8845"
/dev/sda9: LABEL="Data" UUID="262E15C32E158D45" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a984dc95-27c9-4378-91dc-ef364a887afd"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="6002219b-bfcc-48d7-ad9e-8b241fc43bab"

and output of /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=c86e443e-6f16-41ed-ab74-269861d79e05 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=2AC0-616C  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sda7 during installation
UUID=5860e919-7209-4cd2-8576-619df3114ab2 /home           ext4    defaults        0       2
# swap was on /dev/sda6 during installation
UUID=985ef0a6-6275-4423-ba18-c8919463410c none            swap    sw              0       0

If I understand correctly the UUID's match? Just the sda numbers shifted?

This is also a potentially useful log, from /var/log/boot.log:

[FAILED] Failed to start File System Check on /dev/disk/by-uuid/5860e919-7209-4cd2-8576-619df3114ab2.
See 'systemctl status "systemd-fsck@dev-disk-by\\x2duuid-5860e919\\x2d7209\\x2d4cd2\\x2d8576\\x2d619df3114ab2.service"' for details.
[DEPEND] Dependency failed for /home.
[DEPEND] Dependency failed for Local File Systems.
[DEPEND] Dependency failed for Clean up any mess left by 0dns-up.

I am booted into Ubuntu now, but with the method mentioned above (From recovery). If there are any other logs that might help you understand the situation, let me know and I'll edit them in.

Edit1:

If I run the following command: systemctl status -l "systemd-fsck@dev-disk-by\\x2duuid-5860e919\\x2d7209\\x2d4cd‌​2\\x2d8576\\x2d619df‌​3114ab2.service" it says the service is loaded but inactive (dead). When I tried to restart it, I get the following output:

A dependency job for systemd-fsck@dev-disk-by\x2duuid-5860e919\x2d7209\x2d4cd\xe2\x80\x8c\xe2\x80\x8b2\x2d8576\x2d619df\xe2\x80\x8c\xe2\x80\x8b3114ab2.service failed. See 'journalctl -xe' for details.

If I check the logs then, journalctl -xe returns the following:

okt 24 23:25:05 cybermyth kernel: EXT4-fs (sda8): error count since last fsck: 1864
okt 24 23:25:05 cybermyth kernel: EXT4-fs (sda8): initial error at time 1508441061: ext4_find_extent:915:
okt 24 23:25:05 cybermyth kernel: EXT4-fs (sda8): last error at time 1508444203: ext4_find_extent:915: in
okt 24 23:27:26 cybermyth sudo[5452]: pam_unix(sudo:session): session opened for user root by (uid=0)
okt 24 23:27:26 cybermyth systemd[1]: Unnecessary job for dev-disk-by\x2duuid-5860e919\x2d7209\x2d4cd\xe2

Additionaly, this are the logs from journalctl -u "systemd-fsck@dev-disk-by\\x2duuid-5860e919\\x2d7209\\x2d4cd‌​2\\x2d8576\\x2d619df‌​3114ab2.service"

okt 24 23:27:26 cybermyth systemd[1]: systemd-fsck@dev-disk-by\x2duuid-5860e919\x2d7209\x2d4cd\xe2\x80\x8
okt 24 23:27:26 cybermyth systemd[1]: Dependency failed for File System Check on /dev/disk/by-uuid/5860e9
okt 24 23:27:26 cybermyth systemd[1]: systemd-fsck@dev-disk-by\x2duuid-5860e919\x2d7209\x2d4cd\xe2\x80\x8
  • Let's see what systemctl status -l "systemd-fsck@dev-disk-by\\x2duuid-5860e919\\x2d7209\\x2d4cd2\\x2d8576\\x2d619df3114ab2.service Says. It's not immediately obvious why /home switched from /dev/sda7 to /dev/sda8 either. It looks like you also shrunk the Linux partition and put a swap partition after it? – jdwolf Oct 23 '17 at 21:32
  • @jdwolf I've added the logs. I've shrunk the linux /home partition, but I'm almost 100% sure, I didn't put the swap partition after it. I just added a new Windows partition on the free disk from shrunken /home partition. – mythic Oct 24 '17 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.