I have updated my Ubuntu to 17.10 and I have a bug with repeating keys.

When I hold down any key, it repeats differently (sometimes 5 times, sometimes 3 times etc).

Using Lenovo Ideapad 700

  • 1
    In my experience, if key repetition works erratically and not as configured in the keyboard settings, that's a hardware issue. Clean the keyboard below the keys and make sure that the contacts aren't covered in anything. – David Foerster Oct 24 '17 at 12:51
  • 3
    In my experience, if "key repetition works erratically and not as configured" immediately after I've done an OS upgrade, that's a software issue. – Francis Norton Nov 1 '17 at 21:40
up vote 21 down vote accepted

There seems to be something wrong with peaq_wmi module. You can try to blacklist it (worked in Kubuntu 17.10):

sudo su
echo "blacklist peaq_wmi" >> /etc/modprobe.d/50-blacklist.conf

Reboot your machine and everything should be ok. Hope this helps.

Found it here: https://forums.opensuse.org/showthread.php/527307-Keyboard-repeat-problem

  • 1
    Worked also on my Lenovo Flex 2 14 and Ubuntu 17.10; thanks a lot – Tom D. Oct 28 '17 at 8:48
  • 1
    Awesome fix - another satisfied Lenovo Flex 2 14 and Ubuntu 17.10 customer! – Francis Norton Nov 1 '17 at 21:51
  • 1
    Thanks @mgray. Any idea what peaq_wmi is, and what repercussions it will have on other OS operations? Fix works well for me too by the way. – Spider Nov 14 '17 at 7:14
  • I had the same problem in 16.04, and this solved it. Another symptom of the problem: run xev and see a steady stream of key events with key code 221. – Don Kirkby Jan 15 at 1:55
  • 1
    It also fixed some strange bug on tooltips I was having where the tooltips duration was inconsistent, sometimes they just flashed in less than 1 second, somethings they just not appeared. – TalesM Feb 19 at 1:16

After looking for a solution I tried the answer above about doing

sudo su
echo "blacklist peaq_wmi" >> /etc/modprobe.d/50-blacklist.conf

but still did not work (Tested with Lenovo Yoga 4 & Dell 2-in-1 Inspiron 7000) Basically Ubuntu and 2 in 1 devices hate each other that's my conclusion (Don't get me started with Touch events).

Anyway after upgrading Ubuntu to the latest (At least since today) and going to Universal Access and enabling Repeat Keys, it works now and has been working on all apps that I tested and worked on (eg: Firefox, Chrome, LibreOffice, Gnome Panel, etc...)

enter image description here

So you have the option of updating Ubuntu and seeing if that fixed it. If not using the Universal Access option and if not, applying the blacklist option for the peaq_wmi (European OEM for 2-in-1 Devices it looks like). So this would make sense because it only happens using 2-in-1 devices. That's my feedback so far handling the stress of trying to solve this.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.