7

After upgrading from 17.04 to 17.10 my VirtualBox wont start:

$ VBoxManage --version
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (4.13.0-16-generic) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.
5.1.18r114002

$ sudo /sbin/vboxconfig
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.

/var/log/vbox-install.log :

make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/4.10.0-19-generic/build -j8 modules
make[1]: warning: -jN forced in submake: disabling jobserver mode.
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (        \
echo >&2;                           \
echo >&2 "  ERROR: Kernel configuration is invalid.";       \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";  \
echo >&2 ;                          \
/bin/false)

What would be my course of action? Thank you

  • You can start with installation of dkms, linux-image-generic, linux-headers-generic packages. – N0rbert Oct 23 '17 at 18:42
  • @N0rbert I used sudo apt-get install and all these packages were already the newest version. – Tom Smith Oct 23 '17 at 19:10
  • What kernel version do you use now? Post uname -r. – N0rbert Oct 23 '17 at 19:14
  • @N0rbert 4.13.0-16-generic – Tom Smith Oct 23 '17 at 19:20
  • sudo dkms -k 4.13.0-16-generic may help. – N0rbert Oct 23 '17 at 19:24
6

Upgrading to latest version solved the problem: http://ubuntuhandbook.org/index.php/2017/10/virtualbox-reached-5-2-major-release-how-to-install/

  • 1
    it didn't work in my case – David Hofmann Nov 10 '17 at 0:14
4

sudo apt-get install linux-headers-generic linux-headers-lowlatency linux-headers-4.13.0-16-lowlatency linux-headers-4.13.0-16-generic and reinstall Virtualbox or virtualbox-dkms

0

I have installed latest VirtualBox(5.2.8 ATM) on Ubuntu 17.10 and it did not launch.

Solution:

sudo apt install -f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.