19

I like to switch workspaces via Super+Number. But unfortunately the default behavior in Ubuntu for Super+Number is to select applications from the dock.

Is it possible to disable that functionality? I've tried overriding the keyboard shortcuts but it doesn't appear to be working.

19

For Ubuntu 17.10 - 18.10

Run the following command in Terminal:

gsettings set org.gnome.shell.extensions.dash-to-dock hot-keys false

This should disable the default behaviour of Super+0...9.

| improve this answer | |
  • 2
    This has frustrated me to no end, thank you very much! – Berend de Boer Jan 10 '18 at 18:36
  • In 19.04 this no longer seems to work. I've even uninstalled the default dock and it still switches, so it seems to be handled somewhere else. – Per Johansson Apr 23 '19 at 6:46
  • 3
    @per See this answer: askubuntu.com/a/1137705/480481 – pomsky Apr 25 '19 at 2:47
16

For Ubuntu 19.04

In addition to Nolf's answer, you can also set these settings on the command line with these commands:

gsettings set org.gnome.shell.extensions.dash-to-dock hot-keys false
gsettings set org.gnome.shell.keybindings switch-to-application-1 []
gsettings set org.gnome.shell.keybindings switch-to-application-2 []
gsettings set org.gnome.shell.keybindings switch-to-application-3 []
gsettings set org.gnome.shell.keybindings switch-to-application-4 []
gsettings set org.gnome.shell.keybindings switch-to-application-5 []
gsettings set org.gnome.shell.keybindings switch-to-application-6 []
gsettings set org.gnome.shell.keybindings switch-to-application-7 []
gsettings set org.gnome.shell.keybindings switch-to-application-8 []
gsettings set org.gnome.shell.keybindings switch-to-application-9 []
| improve this answer | |
10

For Ubuntu 19.04

Install dconf-editor (sudo apt install dconf-editor) and open dconf-editor. Replace the keyboard shortcuts with empty brackets '[]' as shown in the screenshot.

Screenshot of how this is done for supr+5 keyboard shortcut

| improve this answer | |
  • 5
    This works, but the path on 19.04 is /org/gnome/shell/keybindings/, at least for me. – Per Johansson Apr 25 '19 at 5:54
  • 2
    @PerJohansson, you saved my time, thank you. I found out that /org/gnome/shell/keybindings/ has priority over /org/gnome/shell/extensions/dash-to-dock/ – Maksym Ganenko May 27 '19 at 10:09
0

In my experience on Ubuntu 19.04 I have to set both

org.gnome.shell.extensions.dash-to-dock app-hotkey-1 '[]'
org.gnome.shell.keybindings switch-to-application-1 '[]'

in order to deactivate the app launcher shortcut 1. If I change only one of the two settings it does not work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.