1

trying to install tmate on ubuntu 17.10

following instructions on https://tmate.io/ for ubuntu:

sudo apt-get install software-properties-common 
sudo add-apt-repository ppa:tmate.io/archive    
sudo apt-get update                             
sudo apt-get install tmate

fails on sudo apt-get install tmate, seems to have conflict with dependecies:

➜  ~ sudo apt-get install tmate

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tmate : Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable
E: Unable to correct problems, you have held broken packages.

how can it be solved?

1

I had the same problem, as reported here. To have a fully operational Tmate I remove the repository on source-list.d.

sudo rm -rf /etc/apt/sources.list.d/tmate_io-ubuntu-archive-artful.list*

And them installed Tmate normally.

sudo apt update sudo apt install tmate

As described in the issue, the problem should be fixed, but this have worked for me so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.