7

I use Ubuntu 11.10 with xfce & gnome, and am dependent on company network infrastructure for windows shares (as well as Outlook, but more on that later). So I also fall under their password policy, which dictates that I change it every so often. I keep up to date with all updates from Ubuntu.

The first time that I mounted network shares (with a bookmarked smb:// URL), I checked the 'Remember forever' option and it worked just fine. Reboot, mount a network share, no problem, all automatic. Then came the first mandated password change and it took all the fun of working with network shares away, because now I have to fill in the domain and the password after each reboot, no matter how often I check the 'Remember forever' box.

I also compiled 'openchange' in the mean time (out of dissatisfaction with Evolution), which includes a 'samba4' sourcetree. Could that have anything to do with it ?

2

Start the Seahorse password management application and delete the corresponding smb://... entry.

After that, try to access the share again, and it should ask for the credentials again. Set the option to remember it and it should work until the next password change.

This is what I have to do when the Samba/Windows password changes (using Ubuntu 11.10 and Gnome for accessing SMB shares)

  • from 2012 and only one upvote? The new "files" app has crashed since doing this, and a reboot and I haven't been prompted. I've never changed the password, at least not since this OS has been installed (it's only a couple of months old, and I've had this problem forever)... Fingers crossed this was the problem (I should have checked what was in the field before I deleted it) – Madivad Jul 10 '18 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.