9

This question already has an answer here:

I just update my OS to 17.10, and I am using two displays. I just set up the workspaces, so now when I move from one workspace to another one, the windows open on the second display not moving, Its stays on all workspaces? On previous version it was working, when I switch to workspaces its switch the all windows in both displays.

marked as duplicate by pomsky, Videonauth, Charles Green, David Foerster, George Udosen Oct 24 '17 at 16:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

27

This is the default behavior of GNOME-Shell, which is included in Ubuntu 17.10 and up (in contrast to Ubuntu 17.04, which still included Ubuntu's own creation, Unity).

You can change this using the gnome-tweak-tool, which you can install via sudo apt install gnome-tweak-tool. It offers many additional settings to modify the behavior of the GNOME-Shell.

The setting you want to change can be found in the first category, "Workspaces". You can switch between additional monitors being on their own workspaces or workspaces spanning all monitors (the behavior you want and which was the default for Unity).

  • This only solves a part of the problem, but the secondary monitor will still behave awkwardly. See askubuntu.com/a/1125322/16985 for additional fix – törzsmókus Mar 13 at 14:02
  • 1
    @törzsmókus: True, the activity overview on the second monitor is a bit weird (on the 17.10 machine I still have around, it actually shows the windows from all workspaces on the second monitor, instead of none, as described in the linked post). – Graipher Mar 13 at 14:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.