0

I have a HP Compaq 2510p running a clean Ubuntu 16.04.3 that seems to take forever top progress from startup to login screen and then when I finally enter the login password it takes 45 seconds to become ready for action.

$ systemd-analyze blame
         12.481s lightdm.service
         11.002s NetworkManager-wait-online.service
         10.978s colord.service
         10.707s plymouth-start.service
          9.839s apparmor.service
          9.704s plymouth-read-write.service
          3.583s dev-sda5.device
          1.936s ModemManager.service
          1.781s accounts-daemon.service
          1.742s keyboard-setup.service
          1.691s systemd-modules-load.service
          1.676s NetworkManager.service
          1.650s snapd.service
          1.574s thermald.service
          1.542s systemd-udevd.service
          1.475s networking.service
           795ms upower.service
           559ms teamviewerd.service
           511ms grub-common.service
           321ms polkitd.service
           293ms [email protected]
           287ms systemd-logind.service
           276ms console-setup.service
lines 1-23

if it's bloat-ware it must be part of the clean install of Ubuntu because it happens when install completes. This problem began after a system crash and re-install. I was using the "Erase disk and reinstall" option and it kept coming up with "attempt to access outside Disk 0" (I think). I have since found that if I use the "Something else"option and create a Boot, Root and swap partition, the install completed and started up .However, the time it takes for it to proceed from login to desktop ready, has since then taken about 45 seconds. I agree, It's an old laptop, but it seems to be doing very little during this 45 seconds going by the hard drive access light.

3
  • I'll blame bloatware... any reason you're committed to using Ubuntu? Did you try 17.10? Commented Oct 23, 2017 at 3:49
  • can you add the results of systemd-analyze blame to your question?
    – ravery
    Commented Oct 23, 2017 at 5:15
  • It's an old PC. It got a slow C2D CPU, with 2GB of RAM and - unless you have changed - probably a 4200RPM disk. By modern standards it's slow. You may make it a bit faster by adding more RAM, and SSD.
    – vidarlo
    Commented Oct 25, 2017 at 7:49

1 Answer 1

0

Please excuse the generic nature of this reply. I have seen similar questions all over the Web and decided to write one answer for all. As for the 2510, that is the computer I used for testing. The details I'm providing here are based on Ubuntu but the problem and its remedy generally apply to all distros.

Some older computers updated with new Linux systems experience boot problems. They may not boot at all or they may take as long as three minutes to boot. Coincidentally, they either fail to hibernate or take so long to hibernate and dehibernate that the capability is useless. Often this is not because old computers are simply slow but because of a change introduced in the 4.8 Linux kernel, causing a problem with a very common Intel chipset, which includes svideo output. Beginning with this kernel, any computer with this chipset will experience boot problems unless the Linux command line argument "video=SVIDEO-1:d" is included in GRUB_CMDLINE_LINUX. This will significantly shorten both 64-bit and 32-bit boot times but fixes hibernate problems only for 64-bit. No 32-bit system supports hibernate after this point. Further, the boot times for all 4.8 and 4.9 kernel versions are bad (except 4.8.rc1-7). This is finally resolved in 4.10. Kernels 4.8 and 4.9 should just be avoided (they are obsolete anyway).

If you want the fastest boot times, use a pre-4.8 kernel. I would use Ubuntu-desktop 15.04 with kernel updated to 4.7.10. This is the only way to get hibernation in a 32-system. The 64-bit system boots 7% slower than the 32-bit but it is still faster than any later version. If you want a currently supported 32-bit system and are willing to forego hibernation, use any that either are released or updated to a 4.10 or later kernel. Any 64-bit version works after 4.8 with the video fix but for best performance avoid 4.8 and 4.9.

To add the video fix do sudo nano /etc/default/grub. After closing nano do sudo update-grub. Unless GRUB_CMDLINE_LINUX_DEFAULT, which is inserted after GRUB_CMDLINE_LINUX, is blank, "video=SVIDEO-1:d" will not be the last Linux command line argument, which some people say is necessary. It actually can be anywhere.

You can always invoke hibernate with the pm-hibernate command in a terminal (or tty) but to have it an available GUI option you need to create or add to the policy file /etc/polkit-1/localauthority/50-local.d/ com.ubuntu.enable-hibernate.pkla (obviously distro-specific) the following text:

[Re-enable hibernate by default for login1]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate
    ResultActive=yes
[Re-enable hibernate for multiple users by default in logind]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate-multiple-sessions
    ResultActive=yes

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .