12

I have selected the setting 'Automatic Login' from within the default Gnome 3 Ubuntu 17.10 control panel app, but it keeps resetting to 'off' after every restart and does not allow me to automatically login.

Any ideas?

  • Are you using nvidia drivers? – doug Oct 23 '17 at 2:19
  • If not using nvidia drivers (on a desktop machine, laptops should be fine) post the contents of /etc/gdm3/custom.conf also note that the setting in Settings > Details > Users acts like a cover, i.e. whatever you uncover is enabled, what you cover up is disabled. – doug Oct 23 '17 at 2:30
  • I'm using it, this is my custom.conf – elect Oct 23 '17 at 7:32
  • 2
    The problem is the captial letter in the word True in the gdm3 custom.conf – Michael Wheatland Feb 10 '18 at 6:25
  • 2
    "AutomaticLoginEnable=true" instead of "AutomaticLoginEnable=True" – Michael Wheatland Feb 10 '18 at 6:25
11

I had to force the loging screen to use xorg and not wayland (not yet supported by nvidia drivers).

Edit as root the file /etc/gdm3/custom.conf.

sudo nano /etc/gdm3/custom.conf

Change the line

#WaylandEnable=false

to

WaylandEnable=false
  • 2
    Thanks a lot, this works for me in combination with: AutomaticLoginEnable = true AutomaticLogin = <my user name> – amDude1848 Nov 11 '17 at 18:25
3

I think i've found the problem, try to edit /etc/gdm3/custom.conf and write AutomaticLoginEnable=true instead of AutomaticLoginEnable=True in my case

(full lowercase for the word "true")

or uncomment this line if it is...

  • I don't think it's necessary because my /etc/gdm3/custom.confis already "AutomaticLoginEnable=true" but it was commented. I just uncommented it. – Redbob Oct 24 '17 at 11:58
  • In mine it was written AutomaticLoginEnable=True and I had never edited it manually.... Maybe it cal help some people if not you ;) – Paul ALBERT Nov 3 '17 at 11:27
  • 1
    Unfortunately, even for me this solution worked, @Pöl Halbert... I uncommented, because it was true. But, switching in Details > Users panel, it turns Trueand False. Even changing Trueto true, autologin didn't work. – Redbob Nov 6 '17 at 1:32
2

Same issue. I've originally changed the "/etc/gdm3/custom.conf" and simply enabled the "AutomaticLoginEnable=True". This was the whole issue: I didn't notice that "True" has to be lowercase.

EDIT: I was wrong. My autologin works because I'm NOT using the gnome-xorg (the default option for ubuntu) but the gnome classic session. I can't manage to get the gnome-xorg session to work properly unless I setup a timedlogin which is a little unpleasant.

EDIT 2: Ok, I finally got enough of this issue, since it's getting ignored. To solve my issue, since I don't care the least about gdm but I still want to use chrome, I've installed lightdm and changed the autologin in the user settings.

In other words:

sudo apt install lightdm

followed by the usual change in the user settings for the autologin.

0

I can confirm that it's a bug in Settings app. When changing the 'Automatic Login' flag under Details->Users it writes True/False values for AutomaticLoginEnable in "/etc/gdm3/custom.conf". After manually writing the value AutomaticLoginEnable=true the auto-login works.

  • 1
    This doesn't work for me. The AutomaticLoginEnable=true was remarked out in the file, but activating it, didn't change anything. – Simon Rigét Nov 2 '17 at 15:10
  • @SimonRigét - as you already wrote in your answer, both variables are required for auto-login: AutomaticLoginEnable and AutomaticLogin with username. The Settings app writes both variables, but the bug is that it writes True/False with capital letters. – Julius Nov 4 '17 at 22:06
  • 1
    This solution didn't work for me, @Julius and @SimonRigét, not regarding if it's trueor True, the result is the same: nothing works. These two statements are present in /etc/gdm3/custom.conf: AutomaticLoginEnable and AutomaticLogin – Redbob Nov 6 '17 at 1:28
  • And 2 years later this is still an issue... – Enigma Jul 19 at 3:00
0

I had to set two variables, to make it work:

$sudo gedit /etc/gdm3/custom.conf

And insert the lines:

AutomaticLoginEnable = true
AutomaticLogin = <my user name>

The settings app is buggy, to an extend where it's getting useless as of 11.2017. Hopefuly that will change :)

0

I just had problems with GDM 3.28.3 auto login with 18.04 minimal and gnome-core only. GUI froze completely on boot with the error A start job is running for Hold until boot process finishes up and after long research I accidentally found a solution by disabling the boot splash screen:

# disable splash screen on boot
sudo sed -i 's/splash quiet//g' /etc/default/grub
sudo update-grub

Note: To enable the splash again: sudo gedit /etc/default/grub and make sure splash quiet is again within the quotation marks of GRUB_CMDLINE_LINUX_DEFAULT e.g. GRUB_CMDLINE_LINUX_DEFAULT="splash quiet". Apply the new settings with sudo update-grub.

I hope this saves other people's time. If anyone has an idea why this worked for me please let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.