51

I need to remove the annoying new "locking" screen that shows a giant clock: I can't remove it with just moving the mouse (as with any other desktop environment), the animation is slow, and it isn't asking me for a password!

I managed to disable it, just to discover that now I can't lock my screen on purpose, so I can't go away from the computer.

Just to clarify, I want to:

  • After some time the screen could go black, but if I move the mouse or press any key then I can use it directly (like a normal screensaver).
  • If I press super-L then it is locked, and I must type the password to unlock (like a normal lock screen).

I found several "solutions", but none seems to work:

  • 2
    You need to file a bug report against the extension - github.com/lgpasquale/… – Panther Oct 23 '17 at 2:17
  • 5
    Just a pointer. you can start typing your password without clicking and dragging the screen shield first. – pomsky Oct 23 '17 at 7:44
  • @Panther Looking at the extensions github it has sitting idle since June, and on the extensions page and in the issues people are complaining that it does not work anymore without anything happened. I do not think that this extension is a real solution right now. – Videonauth Oct 23 '17 at 15:41
  • 2
    @pomsky: there isn't any password to write. Also, if this was a screen saver (as it should be) then my password keystrokes could go to any app... not a good idea from a security point of view. – estebarb Oct 24 '17 at 16:49
  • 2
    I moved to KDE to get around this. – HellionWisp Nov 16 '17 at 2:20
12

Open Ubuntu Software and install the GNOME Shell Extension called:

Disable Screen Shield

This works for Ubuntu 18.04

Source: Disable Screen Shield Disable Screen Shield

  • Doesn't work for me. – Robert Baker Jan 16 at 0:34
  • This solution no longer works. The extension fails on recent versions of gnome. – CoreyOConnor Jun 1 at 17:12
8

Actual solution depends on exact requirements, but these may provide work-arounds (specifically, talking about the gnome 3 screen curtain, illustrated here ):

  • if you desire to have a normal basic screen lock enabled, yet don't want the "swipe-up screen curtain", then you may actually just type your password on the curtain screen without clicking/scrolling/mousing/etc, and it will work to unlock the screen. (Note: this assumes that only one account is configured to appear on the login greeter screen.)
  • it seems the screen curtain itself can't be disabled (a couple gnome-shell extensions have mixed reports of either no longer working (ubuntu 17+), or not working consistently), so it appears we're stuck with it for now. But given that you can type your password into it, it's mostly just an (unintuitive) aesthetic issue.
  • also, Esc will "swipe up" (and down), so you don't have to actually use the mouse.
  • there's always KDE (given gnome's usability trajectory, you might give this serious consideration)
  • 3
    Esc won't work for me. And just typing password on a multi-user machine doesn't work. – ziggystar May 9 '18 at 16:21
  • Not purely aesthetic, sometimes I can't get out of he screen - must ssh into laptop and kill X or force a reboot. – Robert Baker Jan 16 at 0:35
  • I've since switched to kubuntu (KDE), so I no longer have the issue, but possibly going to a virtual terminal (Ctrl+alt+f1, etc) and killing/disabling the screen lock might work (...is it gnome-screensaver-command --lock or loginctl unlock-session ? possibly must set DISPLAY? not sure, but worth a shot). – michael Jan 16 at 5:36
  • Due to bugs in the screen shield none of the above are guaranteed to work. – CoreyOConnor Jun 1 at 17:13
4

The "issue" is with GDM. After switching to KDE I changed to Lightdm, and I noted that in Gnome the lock screen was changed as well :D .

So, the solution is not using GDM, for example:

sudo dpkg-reconfigure lightdm # For previous Ubuntu default
4

Like estebarb previously stated, using lightdm fixes the issue for me on 18.04 LTS and 18.10. However switching to KDE isn't necessary. GDM just needs to be disabled/replaced with lightdm

Just open a terminal and run:

sudo apt-get install lightdm

select lightdm, then press ok

display manager selection screenshot You should be able to see your changes by logging out. Then press Ctrl+Alt+F1 (tty1) and login there. then run:

sudo service gdm3 stop

then start lightdm with:

sudo service lightdm start

if it does jump right into lightdm you might have to press Ctrl+Alt+F7 to move back to tty7.

  • Seems like you also need to restart the machine for it to take effect. – wjandrea Apr 30 at 2:18
  • @wjandrea right, I edited my answer to get there with a reboot. – Axios May 1 at 3:08
  • Ah, I didn't even think of using a TTY. Though, on 18.04, the login screen runs on TTY1, and the desktop runs on TTY2. – wjandrea May 1 at 3:12
  • oh so F7 is pointing to tty1, cool. – Axios May 1 at 3:16
0

This was bugging me when setting up Ubuntu 18.04 VMs in Hyper-V under Windows 10.

I finally found

gsettings set org.gnome.desktop.session idle-delay 0

seems to disable the curtain, after disabling the screen lock through the GUI or a separate gsettings command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.