4

The tl;dr about this question is - Is my radeon 520 dedicated card working fine? Do I need to set "xrandr --setprovideroffloadsink radeon Intel" in Wayland to configure hybrid graphics? Xrandr is not working well in weston/wayland.

Long version:

I installed Ubuntu 17.10 on my newly bought HP Laptop (Model: HP 15-BS576TX) which has a dedicated AMD 520 2GB DDR3 graphics card and Intel HD 620 onboard graphics in a Kabylake Core i5 processor system. This is the first time I'm installing Linux on a hybrid graphics card setup on a laptop.

Now, Ubuntu 17.10 defaults with Xwayland instead of Xorg/XFree86. I find it confusing to configure AMD Radeon 520 dedicated graphics. The confusing part is xrander --listproviders only list the intel hd 620 integrated graphics.

xrandr --listproviders
Providers: number : 0

But, lspci -knnn shows that AMD Radeon 520 card is detected:

01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 M520] [1002:6660] (rev 83) Subsystem: Hewlett-Packard Company Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430] [103c:832b] Kernel driver in use: radeon Kernel modules: radeon, amdgpu

and Integrated Intel HD 620 graphics:

00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 620 [8086:5916] (rev 02) Subsystem: Hewlett-Packard Company HD Graphics 620 [103c:832b] Kernel driver in use: i915 Kernel modules: i915

lshw -C video *-display
description: VGA compatible controller product: HD Graphics 620 vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 02 width: 64 bits clock: 33MHz capabilities: pciexpress msi pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:128 memory:b0000000-b0ffffff memory:a0000000-afffffff ioport:6000(size=64) memory:c0000-dffff *-display description: Display controller product: Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 M520] vendor: Advanced Micro Devices, Inc. [AMD/ATI] physical id: 0 bus info: pci@0000:01:00.0 version: 83 width: 64 bits clock: 33MHz capabilities: pm pciexpress msi bus_master cap_list rom configuration: driver=radeon latency=0 resources: irq:129 memory:90000000-9fffffff memory:b1200000-b123ffff ioport:5000(size=256) memory:b1240000-b125ffff

I'm booting with radeon.modeset=1 which is added to the grub bootloader entry.

Now, if I run any app with DRI_PRIME=1 it works and shows below info:

:~$ DRI_PRIME=1 glxinfo |grep -i Opengl* OpenGL vendor string: X.Org OpenGL renderer string: AMD HAINAN (DRM 2.50.0 / 4.13.0-16-generic, LLVM 5.0.0) OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.2 OpenGL core profile shading language version string: 4.50

So, I assumed Radeon 520 is working fine. Then, noticed that there is no mention of gallium 3d? But, why Xrandr is not showing dedicated card as one of the providers?

I see that there is amdgpu driver module also loaded. From the list, R520 card seems to be supported by the radeon driver.

lsmod |grep radeon radeon 1470464 0 ttm 94208 2 amdgpu,radeon i2c_algo_bit 16384 3 amdgpu,radeon,i915 drm_kms_helper 167936 3 amdgpu,radeon,i915 drm 356352 28 amdgpu,radeon,i915,ttm,drm_kms_helper

Wnat needs to be done now? I have no custom scripts or files placed in /etc/X11 directory.

Do I need to remove any xserver drivers? like xserver-xorg-video-amdgpu?

  • I can't tell what your question is. Many x apps do not work in wayland , xrandr is one that does not work. You can run an x session but what makes you think you need to start removing stuff? – Panther Oct 22 '17 at 23:30
  • @Panther the problem is, in wayland session the hybrid graphics is not detected and configured. If I run DRI_PRIME=1 xyz it will run as verified by radeontop tool. However, as shown in the below screenshot, Ubuntu or wayland does not auto-configure it. Gnome settings info should ideally list both the integrated and dedicated card in information. But, it is not so. Neither is any mention about Gallium 3D working with this radeon card. image.ibb.co/hHv3qm/amd_intel_hybrid_gfx.png – Confguy2016 Oct 26 '17 at 11:01
  • In the tl;Dr you answered your own question. Wala d does not support xrandr. You may consider filing a bug report against wayland – Panther Oct 26 '17 at 15:22
  • As of now, I filed a new bug report in Ubuntu BTS about wayland. But, it seems like there are a lot of components that are affected like gnome-control-centre which is not showing dedicated card and nicely autoconfigure it, XrandR which is now just an Xorg tool no more working good in Wayland session. – Confguy2016 Oct 27 '17 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.