0

I have spent about 4 days searching the 9000 fstab posts, none of which answer my question. Recently I needed to reinstall Ubuntu 16.04 LTS because reasons. Anyway, this time around, I seem unable to mount my fixed hard drives to my file system. If I type

sudo mount /dev/sdb1 /home/spooky/Songs

it works fine. That's great, wonderful, except whenever I reboot, I have to type that in manually. If I put that command into /etc/rc.local nothing happens at boot up (well, that's not true, it prevents me from a manual mount until I remove it again and reboot).

Before the clean install, I had it in fstab, but for some reason that isn't working any more.

The result of sudo blkid:

[some stuff]

/dev/sdb1: LABEL="Music" UUID="dc50cbf0-e046-4778-ba1a-1b85d65a1ea0" TYPE="ext4"
PARTUUID="d7e56509-01"

/dev/sdc2: LABEL="Movies" UUID="71f74e32-a760-463b-bec0-c06991ebb52f"
TYPE="ext4" PARTUUID="d56e36e4-02"

[more stuff]

So into fstab, I added the lines to the EOF (the rest of which has remained unchanged since install):

UUID=dc50cbf0-e046-4778-ba1a-1b85d65a1ea0  /home/spooky/Music   
 ext4  defaults  0  2

UUID=71f74e32-a760-463b-bec0-c06991ebb52f  /home/spooky/Videos  ext4  defaults  0  2

and as a prize, I am forced into the debug mode thingy and have to remove them to be able to reboot.

What am I doing wrong? how can I fix it without rebooting every 4 minutes for a continuous 4 hours after working through every website and page I can find that's vaguely related to my problem?

I'm not an idiot (when it comes to Linux), but this is stumping me big time so I'm assuming I'm missing something simple, especially as it works perfectly fine when I do it manually, just no automated method works.

6
  • you EITHER provide UUID (unique identifier) OR device (/dev/sdb1). your command was interpreted as mounting UUID.. to a device directory (not allowed; its not a real directory but a special device.file). your specified type of fs was "/home/spooky/Music" (what fs is that??) -- ie. extra field caused your fstab to be misinterpreted.
    – guiverc
    Oct 22, 2017 at 23:26
  • your manual example uses a different directory I note, you're trying to mount to real directories?
    – guiverc
    Oct 22, 2017 at 23:29
  • yes to real directories, something that was working perfectly fine for about 3 years prior to last weeks re-install of the OS from scratch. It's where all my programs and scripts that use those drives point to, so despite this problem, it's a much easier approach than going through literally thousands of scripts to see which ones refer to it. I have a lot of automation happening. Oct 22, 2017 at 23:57
  • have you tried using fstab to mount to different directories (eg. /home/spooky/testing)... I only mount to directories I create, and I think Music & Videos are auto-created which may mean they are links/special (check with stat or files maybe). if this works delete & re-create the directories if you need those names.
    – guiverc
    Oct 23, 2017 at 0:08
  • I've tried it with "songs" and "films" instead; and again, it worked fine before this week for many years with exactly the same OS installed (from the DVD), so i would doubt that changed much. But yes, i had tried that Oct 23, 2017 at 0:33

1 Answer 1

1

After considerable research it was because it was placing them into the /home tree. I didn't believe they to be the case because it was working fine previously, but i still don't know why that was. I have since used the /media tree and made my chosen path point to it, allowing all my software that utilizes those drives work properly. So now I'm a happy camper, per se.

1
  • It does not seem reasonable that the reason is that you were using the /home tree. Is /home on a partition separate from /, or encrypted, or part of an LVM? Oct 29, 2017 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.