7

Icons don't appear in dropdown menus in Eclipse. I know that in Gnome this bug can be cured by this way: Icons on menus have disappeared but it doesn't work in Unity. Any suggestions?

Thanks in advance.

8

I just had the same issue in Eclipse Indigo in Ubuntu 11.10. Ubuntu Tweak did the trick for me.

Just go to Tweaks > Miscellaneous > Menus have icons

enter image description here

I also enabled Buttons have icons for good measure.

Before: enter image description here

After: enter image description here

  • Hooray. That's been bothering me for a while ! As an aside, I am running 14.04 with Cinnamon. Fix was Preferences | Themes | Other Settings and then 'Show icons in menus' (and the related 'Show icons on buttons). Thank you. – Nicholas Mar 11 '16 at 19:19
6

For Ubuntu 12.10, install Gnome Tweak Tool and enable icons in Theme

5

For Ubuntu 14.04 I couldn't find that setting in either unity-tweak-tool or gnome-tweak-tool. While you can use gconf-editor, it has no effect in eclipse. Instead the following worked for me:

gsettings set org.gnome.desktop.interface menus-have-icons true
gsettings set org.gnome.desktop.interface buttons-have-icons true
  • Ok well thatth might be where the setting is, but it has no effect – dan carter Nov 25 '14 at 0:26
  • On Kubuntu, there is the possibility to configure the icons for buttons directly in the system settings (-> Style -> GTK). That fixed the issue for me without installing any additional tools. – bully May 22 '15 at 12:15
  • Have changed the answer from gconf-editor to gsettings which does work – dan carter Jun 8 '15 at 5:06
0

On Ubuntu 16.04, use:

dconf write /org/gnome/desktop/interface/menus-have-icons true
dconf write /org/gnome/desktop/interface/buttons-have-icons true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.