2

so this morning I woke up and went to SSH to one of my VPS servers. I was alerted that an update was available; in which I was recommended to run the following command:

sudo do-release-upgrade

So, I updated the server as it instructed me to. When it was completely updated to the new 17.10, I decided to finish up some tasks and update my main desktop OS to the new 17.10. Again, I ran the same sudo do-release-upgrade command and the update initiated.

I have now counted about 3 new errors or issues with my machine that I need help with. I will count down while trying to explain as thoroughly as possible. Many thanks in advance :)

Problem #1

The first thing that I realized was that the boot system is MUCH slower than before. I don't know if it was due to new configurations (I installed the default package maintainer's configuration files during the upgrade) or what, but it's pretty annoying that I have to wait > 3 mins before it even brings up the login screen. I tried to do F12 while it was booting to show the boot processes and such, but for some reason, it wasn't giving me anything.

* Update

I'm going to attempt to follow these instructions and see if it works: https://askubuntu.com/a/249117

Problem #2

My next problem is kinda strange. I'm running Ubuntu Linux on a Razer Blade Stealth (the first gen), so I've always had problems (like most others) with the OS recognizing my network cards, and webcam. This problem here lies in the network area.

Whenever I boot my pc up, most likely it is automatically connected to my home internet (wifi, not ether.). The issue is that even though I'm connected to my internet, it usually doesn't allow me to access the internet's broadband (ie going to google.com) immediately. Though if I give time to "do it's thing" then I can get on the internet after a couple minutes. This is extra weird because I've heard of it either working perfectly or not at all; though mine seems to work and not work at the same time?? This is really inconvenient and is kinda annoying. Please help me with this crappy pc ;(

Problem #3

At the ending of the upgrade process, it instructed me to reboot my machine. So I did, and I waited, and waited, and waited... When it finally booted back up and brought me to the new login screen (Pretty nice btw), I did so and immediately open a terminal session to finish off the installation. I ran the usual update/upgrade commands:

sudo apt update; sudo apt upgrade -y; sudo apt autoremove

I then noticed something strange... The following error codes is what it spit back out to me:

┌─[tcd3v@bladestealth]─[~]
└──╼ $sudo apt upgrade -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up python-klein (17.2.0-1) ...
  File "/usr/lib/python2.7/dist-packages/klein/test/py3_test_resource.py", line 26
    async def leaf(request):
        ^
SyntaxError: invalid syntax

dpkg: error processing package python-klein (--configure):
 subprocess installed post-installation script returned error exit status 101
Setting up mysql-server-5.7 (5.7.19-0ubuntu1) ...
mysql_upgrade: Got error: 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: error processing package mysql-server-5.7 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.7; however:
  Package mysql-server-5.7 is not configured yet.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 python-klein
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is not really limiting me, but it would be nice to know how to fix this so my machine can upgrade properly.

Computer Specs:

Linux bladestealth 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:35:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

https://imgur.com/a/PX2Sn

closed as too broad by pomsky, Videonauth, Zanna, David Foerster, Jeremy Bicha Oct 24 '17 at 15:54

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to Ask Ubuntu! It is preferred if you can post separate questions instead of combining your questions into one. That way, it helps the people answering your question and also others hunting for at least one of your questions. Thanks! – Videonauth Oct 24 '17 at 0:35