7

I've installed Ubuntu 17.10 on the Xiaomi Notebook Ari 13'3 but I couldn't get the fingerprint function running for logon. The Fingerprint GUI sees no device at all. Maybe there are necessary drivers for the Xiaomi Fingerprint sensor?

Here's the output (partial) of lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 8087:0a2b Intel Corp.
Bus 001 Device 003: ID 04f3:0c1a Elan Microelectronics Corp.
Bus 001 Device 002: ID 04f2:b5a3 Chicony Electronics Co., Ltd
...
8
  • 1
    Please edit your question to include the output of the lsusb command. This should enumerate the fingerprint reader device, which will help us better troubleshoot your issue.
    – richbl
    Jan 3, 2018 at 17:26
  • @richbl the result is Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 004: ID 8087:0a2b Intel Corp. Bus 001 Device 003: ID 04f3:0c1a Elan Microelectronics Corp. Bus 001 Device 002: ID 04f2:b5a3 Chicony Electronics Co., Ltd Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    – MetaColon
    Jan 4, 2018 at 14:37
  • @MetaColon, I edited your question to make the output of lsusb more legible.
    – richbl
    Jan 4, 2018 at 15:48
  • @richbl As a matter of fact, it's not my question, I just have the same problem.
    – MetaColon
    Jan 4, 2018 at 15:49
  • The key to what lsusb tells us is that the fingerprint device is from Elan Microelectronics Corp (device 04f3:0c1a). We can use that information to better troubleshoot your issue.
    – richbl
    Jan 4, 2018 at 15:49

1 Answer 1

1

Had the same issue solved by installing fingerprint+gui package. After adding this package Ubuntu recognised the fingerprint HW.

Add ppa source:

sudo apt-add-repository ppa:fingerprint/fingerprint-gui

Update source list:

sudo apt-get update

Install necessary packages:

sudo apt-get install libbsapi policykit-1-fingerprint-gui fingerprint-gui

Installing this packages will overwrite/remove default package "policykit-gnome" In case you decide to remove this PPA, reinstall default policykit.

4
  • helped through different versions of Ubuntu togather with 17.10
    – Petr
    Jan 5, 2018 at 15:44
  • did this work for a xiaomi laptop? Tried this on mine without luck. Jan 7, 2018 at 0:25
  • Didn't work for me.
    – MetaColon
    Jan 7, 2018 at 19:18
  • 6
    The installation did work, but the interface showed the message "No Devices Found". Did you test it with the device 04f3:0c1a from Elan Microelectronics Corp?
    – MetaColon
    Jan 8, 2018 at 16:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.