6

I have the problem with Alt+Shift shortcut.
I cannot set up to change keyboard layouts.

I have seen How to reset Keyboard Shortcuts on Ubuntu 17.10 and Ubuntu 17.10 can't change the input switching shortcut to alt+shift.
I tried to fix the issue with Tweak tool. Anyway, it doesn't work and issue is still there.

I use Unity.

Is there another approach?

  • You can't use < Alt + Space > for keyboard layout switching. It opens window drop-down menu. So there will be conflict. You can set < Super + Space > or < Alt + Shift > (in GNOME Tweaks). – N0rbert Oct 22 '17 at 19:34
  • Does it work if you unbind the shortcut from its other action in the shortcut settings of GNOME and then use the GNOME Tweak Tool method in askubuntu.com/questions/967364/…? – David Foerster Oct 22 '17 at 20:04
6

As I suggested in Ubuntu 17.10 can't change the input switching shortcut to alt+shift :

You can achieve this using gsettings (command-line configuration tool).

  1. Set forward switch to Shift+Alt(left)

    gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Shift>Alt_L']"
    
  2. Set backward switch to Alt+Shift(left)

    gsettings set org.gnome.desktop.wm.keybindings switch-input-source-backward "['<Alt>Shift_L']"
    

To see the current setting value use get command:

    gsettings get org.gnome.desktop.wm.keybindings switch-input-source
    gsettings get org.gnome.desktop.wm.keybindings switch-input-source-backward

Examples of other key bindings:

    <Primary>space, Alt_R, <Shift>Control_R, <Shift><Super>space

Changes will take effect immediately.

  • 2
    It does not work for unity in 17.10. Only for gnome. – avtomaton Jan 16 '18 at 8:24
  • Oh, thank you very much. It solved my problem. – Robotex Feb 5 '18 at 20:20
  • @avtomaton You are right. I didn't notice Unity tag at the first time. Sorry. But I'll better leave my answer here as it helps misguided Gnome users like me :) – Evgeny Kharitonov Mar 7 '18 at 15:55
  • it works for Unity session on 17.10. – Vader B Mar 20 '18 at 9:53
0

Welcome to new modern GNOME.

This is known bug 1725706 - Unable to change window state with keyboard in gnome shell (such as Always on _Top - < Alt+Space+t >).
The best solution is to drop GNOME and switch to MATE DE (see this answer).

Also you can try to use GNOME FlashBack with Metacity (sudo apt-get install gnome-panel).

  • 1
    Thanks for the answer. Just to add: I use Unity, not Gnome. – djm.im Oct 22 '17 at 18:56
  • @djm.im You mention that in question. That changes everything. – pomsky Oct 22 '17 at 19:02
  • I forget to mention it. – djm.im Oct 22 '17 at 19:08
  • 2
    @djm.im: Could you please edit your question, when you want to clarify something or add information? It’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons. Thanks. – David Foerster Oct 23 '17 at 8:50
  • is it really a gnome and keyboard issue? I mean, I log in using the unity option at the gnome log in screen, and I also have these problems . Also the "window state" seems unchangeable not only with the keyboard, but with the mouse too. I used to right click on the window top bar and to check the "always on top" item, but now no context menu appears – user907860 Oct 28 '17 at 15:21
0

I'v got the same problem and after some actions shortcut ALT + SHIFT is working.

Here is what I did:

  1. Unbind same combination in Gnome Tweaks.
  2. sudo apt purge unity && sudo apt autoremove.
  3. sudo apt install unity.

And everything is fine now. Hope that helps.

0

I have been using the Menu key since October 2017. One has to set it in the Gnome tweaks:

the menu option to change layouts in the gnome tweaks

as well as in "panel -> text entry settings" in the upper right corner of the screen.

When I first found this question 6 months ago, I thought it was a bug and would be fixed later, so I didn't posted this "workaround". But now it looks like it can be appropriate to post an answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.