13

I updated to 17.10 from 17.04.

I activated the fractional scaling by running the following command.

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

Then, I changed 125% scale. The scale was changed, but the fonts and icons are so dirty.

enter image description here

The launcher icon and font in Google Chrome and other application except the system setting are dirty.

How can I resolve this problem?

For some reason, font in the system setting is not dirty...

  • This is fixed in GNOME 3.32 (at least for wayland windows and shell), so we can probably close this question :) – Treviño Mar 20 at 15:14
  • 1
    In my experience the problem persists in GNOME 3.32. Specifically any application using XWayland (Firefox, Chrome/Chromium, Electron apps) has blurry fonts when fractional scaling is enabled (even when the scaling percentage is an integer). An acceptable answer may be a workaround such as how to get these applications to work on Wayland natively (rather than XWayland), or at least not have blurry fonts. – user1475412 Mar 20 at 18:44
5

Looks like it's a work in progress. GNOME only supports integer scaling properly (source).

Quote:

Currently, we only allow to scale windows by integral factors (typically 2). This proves somewhat limiting as there are many systems that are just in between the dpi ranges that are good for scale factor 2, or unscaled.

  • I don't think it's entirely due to the fractional part of the scaling though. 1x vs 2x is vastly different in Chrome, Chromium, and Firefox. – Zach Moazeni Oct 24 '17 at 13:03
  • 5
    Even when setting scale factor to 200% (2x), the fonts of non-native apps like Chrome or Firefox look very blurry if gnome fractional scaling is enabled. They definitely look even worse with fractional scaling than if rendered directly to low dpi 1920x1080 screen without any hidpi support. This problem happens only for non native apps, like Chrome, Firefox, Idea, Slack, etc. Ubuntu GTK3 apps and menus are crisp. I guess the non-native apps are rendered in half of the resolution (2k) and then the framebuffer is upscaled to 4k when needed, causing blur. – Piotr Kolaczkowski Dec 5 '17 at 11:58
  • Also GNOME does not truly even support integer scaling properly for all the apps when using mixed DPI setup with multiple monitors. Non GTK apps seem to have only one scaling factor and moving them from one display to another with different scaling factor does not rescale properly, so you get the UI either twice too big or twice too small. – Piotr Kolaczkowski Dec 5 '17 at 12:05
  • 2
    Same observation here. For now, I'm going to disable fractional scaling again (by calling gsettings set org.gnome.mutter experimental-features "[]") and keep using the existing 2x scaling. – panmari Jan 7 '18 at 14:29
  • Any known update on this issue? – Tsume Jul 5 '18 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.