6

I upgraded Ubuntu to 17.10 and found out that alt key has strange behavior.
If I press Alt+Space, for example, I can see the menu of the active window, but If I press more complicated combination like Ctrl+Shift+Alt+some_letter, it doesn't react. In Ubuntu 17.04 it worked.

The only way of solving this problem I know is to use gnome-tweak-tool. In this gnome-tweak-tool, I can swap key Win (Super) with key Alt. In this case everything works great, but... I would like key Win to be key Win and key Alt to be key Alt. So, may be there is a good solution for this problem?

  • Some people use Caps lock for changing the input language. Possibly, using Caps lock is better workaround then that I mentioned in my question (one key instead of two), but it is still not the best solution – hijack Oct 28 '17 at 5:29
12

There's an simple workaround here:

In case you don't need to switch between keyboard layouts, you can get some shortcuts working again if you use the "Tweaks" tool for Gnome.

sudo apt install gnome-tweak-tool

Then

  1. Open "Tweaks"
  2. Select the tab "Keyboard & Mouse"
  3. Click "Additional Layout Options"
  4. Disable entries in the "Switching to another layout" dialog

In my case this gave me back the "ALT + SHIFT" combinations which are essential in the Eclipse IDE for refactoring.

screenshot

It works beautifully!

  • Mostly correct, but you still can use a shortcut to switch keyboard layouts. You just need to create different shortcut. For example I use Super + Space – Juraj.Lorinc May 5 '18 at 13:50
  • Kudos to you man! – manniL Sep 8 '18 at 20:14
4

I was able to solve this problem using the patch from this ticket. But the latest supported version is 1.19.3 while actual is 1.19.5 so this also requires some changes in patch/shell script to work.

0

It seems that you override ctrl, so you need to install Tweak Tools and to return ctrl's position.

  1. sudo apt install gnome-tweak-tool
  2. Then some magic
    • Launch Tweaks
    • Select "Keyboard & Mouse"
    • Select "Additional layout options"
    • Change "Ctrl Position" (in my case it was at bottom left)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.