21

I was running gnome 17.04 with no issues. I clean installed Ubuntu 17.1 and everything is fine except on shutdown / reboot it hangs with the following error. Only way to turn off is to hard power cycle which may be bad for hardware. How can I troubleshoot this?

Wlp6s0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22)
Wlp6s0: failed to remove key (2, ff:ff:ff:ff:ff:ff) from hardware (-22)
1
7

3 ways to fix this problem:

First way: If you don't wanna make change to grub or changing the grub create other problems or you don't wanna upgrade the kernel:

  • Everytime when you see that error after turning off the pc,just press alt+F7.

Second way: Removing "quiet splash" from the parameters in grub:

  • gksudo gedit /etc/default/grub

    Change:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    To:

    GRUB_CMDLINE_LINUX_DEFAULT=""
    

    Then run:

    sudo update-grub
    reboot
    

Third way:

  • Upgrade to kernel 4.13.6 or higher.
4
  • I'm having this same problem and my wifi is acting like a yoyo since I upgraded to 17.10. Can u pls explain with more details how someone can upgrade to kernel 4.13.6 as I'm still new with linux and ubuntu and all this stuff?? – Nermeen Hussein Dec 3 '17 at 14:16
  • itsfoss.com/upgrade-linux-kernel-ubuntu @NermeenHussein – Sss Dec 3 '17 at 15:31
  • 2
    As mentioned above, removing quiet splash causes booting to fail for several users. Upgrading to 4.14.4 for me caused a "Kernel panic - not syncing: VFS: Unable to mount root fs". Upgrading to 4.14.3 will boot but the same problem remains. Hitting Alt-F7 (not ctrl-alt-F7) is the only thing that works for me. – OrdinaryHuman Dec 9 '17 at 3:01
  • alt f7 working for me, what exactly does this do? I see a few more commands execute shortly thereafter. Might upgrade kernel soon. – edencorbin Dec 15 '17 at 11:34
3

I'm having this same issue, I'd be interested to see what the resolution is. I believe disconnecting from the Wireless connection will allow you to shut down gracefully if you haven't found out, but I'm not entirely sure how to resolve it either.

EDIT: Looks like this is resolved in a new kernel version, but I'd be interested to know if a fix exists.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1720930

3
  • 2
    FYI the suggested 'fix' for this of editing /etc/default/grub didn't fix this issue for me - when I did it, I was no longer able to log in until I reverted the change. Having reverted the change though, the error message seems to have disappeared, although the system still hangs. – walrus Nov 20 '17 at 15:15
  • 1
    Same as @walrus, following the 'fix' in that issue only sent me into an infinite boot loop. As a temp workaround you can try downgrading the kernel from 14.13.0-17-generic to 14.13.0-16-generic, which allowed me to reboot without powering down. Error still shows but at least the reboot process initiates. – OrdinaryHuman Nov 25 '17 at 19:54
  • There is a kernel patched with the fix available linked on that bug, please test it: people.canonical.com/~khfeng/lp1720930 – Treviño May 11 '18 at 16:02
1

I could not fix this issue at all using any solutions given, disabling wifi card options via /etc/modprobe.d/iwlwifi.conf, nothing worked.

What worked for me was changing the MAC address on the actual wifi connection. Somehow something must have been caching that and associating it with some bad wifi / connection state, even after reboot. Maybe it was my router, but it's very weird.

enter image description here

1

I was having this issue when closing the lid of my laptop (entering 'suspended' mode). Once I opened the lid, wifi refused to connect and I was getting [ 183.188182] wlp60s0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22) in dmesg. I tried lots of things and nothing worked. The only thing that really worked for me was restarting my router.

1
  • This was absolutely the answer for me. A key stored in the hardware caused the issue. Other devices could connect to my WiFi. I was able to boot into Windows and connect, but booting into any other Distro (I have 8 on my system) caused the same failure on 3 Ubuntu version, openSUSE, Manjaro and others. I also tried kernel 4.15, 4.13, 4.10 and 4.4 with the same error. Restarting the router fixed everything. This confirms that the issue was hardware, specifically between the wifi card and the router, even though the errors don't make it clear. – Delorean May 17 '18 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.