2

I upgraded to 17.10 last night. Upon reboot, I noticed I couldn't launch gnome-terminal. This morning, I noticed I couldn't open any folders on the Desktop and many applications, whether from the desktop, or my favorites, or the command line. Examples: LibreOffice, evince, gedit. Applications that do work include Firefox and Emacs.

Here is what happens when I try to run Nautilus and evince from the console (Terminology):

rwhe@duell3:~$ nautilus
sys:1: PyGIWarning: Nautilus was imported without specifying a version 
first. Use gi.require_version('Nautilus', '3.0') before import to ensure     
that the right version gets loaded.
Initializing nautilus-dropbox 2015.10.28
Segmentation fault (core dumped)
rwhe@duell3:~$ evince
Segmentation fault (core dumped)
rwhe@duell3:~$

I've already googled the gi.require_version warning and a number of other related topics and followed the advice that worked for other people, with no results, so please don't mark this as a duplicate.

The only change I've made to my system since the upgrade is uninstalling the last vestiges of Ubuntu Mate, and then reinstalling them in the hope of fixing my issue. Again, no visible, relevant results.

Thanks for your time and expertise.

  • 1
    Are you running the default (Wayland?). Try selecting the gear beside the signin button, and select an xorg like gnome-xorg, or ubuntu-xorg. – ubfan1 Oct 22 '17 at 4:48
  • Yes! It works! Thank you! I switched from "Ubuntu" to "Ubuntu on Xorg" and now I can open folders, run Evince, etc. Why are so few other people reporting this issue (that I can find)? Is it my oldish 2013 laptop? Am I uniquely stupid? Did I miss a handout in class? – Ron Hale-Evans Oct 22 '17 at 7:12
-1

Ubuntu 17.10 will default to Wayland instead of X for display, but only when possible, then X is used. The choice should be offered by clicking on the little gear beside the signin button on the login screen. Choices with (Xorg) in them will run X, and should be used for maximum compatibility with programs (your case). If you have a choice with just the "ubuntu" label, that is wayland, and as you have noticed, many programs have problems. I have seen additional choices like "unity" which runs the old unity interface under X. Some people don't even get the gear (live media, virtual machines,...) so cannot even choose, but I think they are defaulting to X, so wont have Wayland issues. It is unclear why Wayland is not even offered in some cases, maybe there were so many problems, there was a last second change. Time will sort these issues out, but for now, if you can run X, you are better off doing so.

  • Perhaps the rules for picking Wayland or X work most of the time for most people, and I am one of a small percentage for whom it doesn't. Thanks again. – Ron Hale-Evans Oct 22 '17 at 16:54
  • Doesn't work when I log into Xorg too. Still getting the same error as mentioned in the question. – Kewal Shah Feb 25 '18 at 8:43

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.