52

I have made .desktop files for Ubuntu 16.04 to access my Google Chrome profiles, but once I upgraded to Ubuntu 17.10 (it worked up to Ubuntu 17.04) they got removed from the dock and I can't pin them back.

Sample File:

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Icon[en_US]=google-chrome
Name[en_US]=Google Chrome
Exec=google-chrome --profile-directory=Default
Comment[en_US]=Chrome
Name=Google Chrome
Comment=Chrome Browser
Icon=google-chrome
Categories=Browser;Internet;
0
78
  1. Create a .desktop file (or, copy if you already have one ready), say my-chrome.desktop, in your ~/.local/share/applications/ directory.
    You may add the following lines to it for a simple, bare-minimum .desktop launcher

    [Desktop Entry]
    Name=My Chrome
    Comment=Chrome my profile
    Exec=google-chrome --profile-directory=Default
    Icon=google-chrome
    Type=Application
    Terminal=false
    

    The keys are as described below

    • Name= Specific name of the application (For this particular example, I used "My Chrome" to avoid confusion with the already existing Google Chrome launcher. You can use any other name.)
    • Comment= A short description of the application
    • Exec= The command to execute in order to launch the application
    • Icon= Icon for the application (You can use an icon provided by your icon theme or an absolute path to an image file.)
  2. Click 'Activities' or 'Show Applications' and search for "My Chrome" (application name as per the Name key). It should appear.

  3. Right click on it and select 'add to favourites'.
    If right clicking on application icon in dock doesn't show "Add to favourites" option, search for the application in Activities screen, and then drag it across to the dock (suggested by Legolas).

If nothing works, see this Q&A: Cannot add custom launcher to Ubuntu Dock (Add to Favorites)

8
  • Is a restart or re-login needed? For me this does not even make the thing show up in the "Activities" dashboard. – Zelphir Kaltstahl Jan 16 '18 at 10:29
  • 2
    @Zelphir Should not be required, but try anyway. If still doesn't work, see this. – pomsky Jan 16 '18 at 10:35
  • 1
    When you put in a path, you can't use ~. Use the full path. When I had ~, nothing showed up. Moving to a full path worked fine. – Virmundi May 28 '18 at 17:47
  • Yes, of course, you can't put ~ in the .desktop file, you'll have to put the full path (there is no ~ in the content of the sample .desktop file though). – pomsky May 28 '18 at 18:01
  • The file did not show up for me in Activities – Zane Hitchcox Sep 30 '18 at 19:30
8

I had the same problem with Firefox Nightly. The following configuration works for me in ~/.local/share/applications/firefox-nightly.desktop:

[Desktop Entry]
Type=Application
Name=Firefox Nightly
#
# WARNING: Remember to fix the path in Icon and Exec
#
Icon=/path/to/firefox-nightly/browser/icons/mozicon128.png
Exec=/path/to/firefox-nightly/firefox %u
Terminal=false
StartupWMClass=Nightly

Without StartupWMClass, the running application is not recognized and the icon is displayed twice on the dock.

1
4

For anyone having troubles, if the application is not appearing in Activities, make sure you don't have a

NoDisplay=true

line in the .desktop file for your application.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.