I have made .desktop files for Ubuntu 16.04 to access my Google Chrome profiles, but once I upgraded to Ubuntu 17.10 (it worked up to Ubuntu 17.04) they got removed from the dock and I can't pin them back.

Sample File:

#!/usr/bin/env xdg-open

[Desktop Entry]
Name[en_US]=Google Chrome
Exec=google-chrome --profile-directory=Default
Name=Google Chrome
Comment=Chrome Browser

3 Answers 3

  1. Create a .desktop file (or, copy if you already have one ready), say my-chrome.desktop, in your ~/.local/share/applications/ directory.
    You may add the following lines to it for a simple, bare-minimum .desktop launcher

    [Desktop Entry]
    Name=My Chrome
    Comment=Chrome my profile
    Exec=google-chrome --profile-directory=Default

    The keys are as described below

    • Name= Specific name of the application (For this particular example, I used "My Chrome" to avoid confusion with the already existing Google Chrome launcher. You can use any other name.)
    • Comment= A short description of the application
    • Exec= The command to execute in order to launch the application
    • Icon= Icon for the application (You can use an icon provided by your icon theme or an absolute path to an image file.)
  2. Click 'Activities' or 'Show Applications' and search for "My Chrome" (application name as per the Name key). It should appear.

  3. Right click on it and select 'add to favourites'.
    If right clicking on application icon in dock doesn't show "Add to favourites" option, search for the application in Activities screen, and then drag it across to the dock (suggested by Legolas).

If nothing works, see this Q&A: Cannot add custom launcher to Ubuntu Dock (Add to Favorites)

  • Is a restart or re-login needed? For me this does not even make the thing show up in the "Activities" dashboard. Commented Jan 16, 2018 at 10:29
  • 2
    @Zelphir Should not be required, but try anyway. If still doesn't work, see this.
    – pomsky
    Commented Jan 16, 2018 at 10:35
  • 1
    When you put in a path, you can't use ~. Use the full path. When I had ~, nothing showed up. Moving to a full path worked fine.
    – Virmundi
    Commented May 28, 2018 at 17:47
  • 1
    Yes, of course, you can't put ~ in the .desktop file, you'll have to put the full path (there is no ~ in the content of the sample .desktop file though).
    – pomsky
    Commented May 28, 2018 at 18:01
  • The file did not show up for me in Activities Commented Sep 30, 2018 at 19:30

I had the same problem with Firefox Nightly. The following configuration works for me in ~/.local/share/applications/firefox-nightly.desktop:

[Desktop Entry]
Name=Firefox Nightly
# WARNING: Remember to fix the path in Icon and Exec
Exec=/path/to/firefox-nightly/firefox %u

Without StartupWMClass, the running application is not recognized and the icon is displayed twice on the dock.


For anyone having troubles, if the application is not appearing in Activities, make sure you don't have a


line in the .desktop file for your application.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .