1

I was updating from 17.04 (just updated itself from 16.04LTS) to 17.10, but ran into the "not enough free space" on /boot problem.

I have already done the whole dance of removing all old kernels, but still don't have enough space (even enabled COMPRESS=xz as suggested elsewhere):

$ df -h /boot
Filesystem      Size  Used Avail Use% Mounted on
/dev/sdb1       236M   49M  175M  22% /boot

and:

$ sudo ls -lah /boot
total 41M
drwxr-xr-x  5 root root 3.0K Oct 21 15:50 .
drwxr-xr-x 29 root root 4.0K Oct 21 14:35 ..
-rw-r--r--  1 root root 1.4M Oct  6 12:45 abi-4.10.0-37-generic
-rw-r--r--  1 root root 201K Oct  6 12:45 config-4.10.0-37-generic
drwxr-xr-x  5 root root 3.0K Oct 21 15:50 efi
drwxr-xr-x  5 root root 1.0K Oct 21 15:18 grub
-rw-r--r--  1 root root  28M Oct 21 15:48 initrd.img-4.10.0-37-generic
drwx------  2 root root  12K Jun 28  2014 lost+found
-rw-r--r--  1 root root 179K Jan 28  2016 memtest86+.bin
-rw-r--r--  1 root root 181K Jan 28  2016 memtest86+.elf
-rw-r--r--  1 root root 181K Jan 28  2016 memtest86+_multiboot.bin
-rw-------  1 root root 3.6M Oct  6 12:45 System.map-4.10.0-37-generic
-rw-------  1 root root 7.3M Oct  6 12:45 vmlinuz-4.10.0-37-generic

The installer requires at least 183MB of free space.

I have even tried to resize partitions with gparted but when I boot from the LiveCD to use gparted I only get a "blue screen of death" - also, I am not terribly excited about fiddling with my boot partition (which will also require me to resize my /home partition, which is encrypted, so the scope for bricking everything is pretty high).

Has anyone else ran into this problem and found a workaround?

Thanks in advance for any suggestions you folks may have.

UPDATE This problem eventually went away, as it turns out 17.10 had done some sort of a partial install (even though I'd stopped it when it said not enough space) so the subsequent sudo apt-get upgrade caused it to complete the system install.

A major issue is that the new kernel it installed seems to have issues with the graphic card or something and was unable to boot, but by using the one that came with 17.04, works just fine.

Still unclear why it wanted so much free disk space, as I currently have three kernels in my /boot and they take still less than 60% of the space.

The suggestion of creating a new partition and then point /etc/fstab to it is a good one, though, so I'm leaving it there for others who may have the same issue.

2 Answers 2

1

You could try using a different version of an Ubuntu emergency disk to run GParted. That said, if an Ubuntu live CD is failing to boot, I'd be reluctant to upgrade the machine to that version -- it sounds like there might be a bug that would cause the entire system to become useless. Instead, I'd stick with the older, and known-working, Ubuntu version for a while.

If you press ahead, then you could try creating a new /boot partition, rather than resize the existing one. After you create the new /boot partition, you'll need to copy the existing partition's files to the new one and modify /etc/fstab to point to the new partition rather than the old one. If your current /boot comes before your root (/) partition (or LVM physical volume), then creating a new /boot after the root (/) partition or LVM is likely to be much safer and faster than trying to move the front of the root (/) partition or LVM. This advice won't help you with your immediate problem, but it's best to avoid moving the start point of any partition, if possible.

A variant on the above advice is to use another disk -- perhaps even a USB flash drive -- to hold /boot. This might be a temporary measure until you get things up and running again; or if you add a new disk permanently, there's likely to be little or no reason not to make this placement permanent.

FWIW, this is a known bug in Ubuntu. Unfortunately, a bug fix (which has been released) can affect only future installations, not existing ones.

1
  • The idea of creating a new partition and then pointing /etc/fstab to it is an incredibly good one, and so obvious I wanted to slap myself for not coming up with it - then again, all great ideas are obvious in hindsight :) Thanks! Oct 24, 2017 at 22:20
0

Try using Gparted from a CD, Also you stated you have a "A blue screen of death". Did PC ever have windows ? As for using Gparted...try deleting all partions the HD. Then create a new partion using the ext2 format. I did this on a PC with windows and then installed Ubuntu from a flash drive, a cd should also work. This worked for me.

1
  • never had any Windoze on this machine - all I get is a blue (empty) screen, no gparted, nothing. Incidentally, your answer does not address the question at all: if all I wanted was to delete all data, I knew exactly how to do that. Oct 22, 2017 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.