My wifi connexion is very unstable after the 17.10 update (from 17.04). I'm experiencing frequent disconnections (every 10~15min) a simple reconnection to the SSID solve the issue.

The card model is:

sudo lshw -class network                                                                                                                                                                                                         
  *-network                 
       description: Wireless interface
       product: QCA6174 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:3a:00.0
       logical name: wlp58s0
       version: 32
       serial: ****
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.13.0-16-generic firmware=WLAN.RM.4.4-00022-QCARMSWPZ-2 ip=192.168.1.49 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:286 memory:dc000000-dc1fffff

The computer is a Dell XPS 13' 9360.

The Wifi was working fine on 17.04 (not great signal but no diconnections).

The diagnostic:

########## wireless info START ##########

Report from: 22 Oct 2017 12:10 CEST +0200

Booted last: 22 Oct 2017 00:00 CEST +0200

Script from: 25 Mar 2017 07:04 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 17.10
Release:    17.10
Codename:   artful

##### kernel ############################

Linux 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:35:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, video.use_native_backlight=1, vt.handoff=7

##### desktop ###########################
i3

##### lspci #############################

3a:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Bigfoot Networks, Inc. QCA6174 802.11ac Wireless Network Adapter [1a56:1535]
    Kernel driver in use: ath10k_pci

##### lsusb #############################

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0c45:670c Microdia
Bus 001 Device 003: ID 04f3:20d0 Elan Microelectronics Corp.
Bus 001 Device 002: ID 0cf3:e300 Atheros Communications, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

##### lsmod #############################

ath10k_pci             45056  0
dell_laptop            20480  0
ath10k_core           352256  1 ath10k_pci
ath                    28672  1 ath10k_core
mac80211              778240  1 ath10k_core
cfg80211              610304  3 mac80211,ath,ath10k_core
wmi_bmof               16384  0
dell_wmi               16384  0
dell_smbios            16384  2 dell_wmi,dell_laptop
sparse_keymap          16384  3 dell_wmi,intel_hid,intel_vbtn
wmi                    24576  2 dell_wmi,wmi_bmof
video                  40960  3 dell_wmi,dell_laptop,i915

##### interfaces ########################

auto lo
iface lo inet loopback
dns-nameservers 127.0.0.1

##### ifconfig ##########################

lo: flags=73  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 3693  bytes 416071 (416.0 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3693  bytes 416071 (416.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp58s0: flags=4163  mtu 1500
        inet 192.168.1.49  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 ****  prefixlen 64  scopeid 0x0
        inet6 ****  prefixlen 64  scopeid 0x20
        inet6 ****  prefixlen 64  scopeid 0x0
        ether   txqueuelen 1000  (Ethernet)
        RX packets 1314397  bytes 1910643192 (1.9 GB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 398128  bytes 49026367 (49.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

##### iwconfig ##########################

lo        no wireless extensions.

wlp58s0   IEEE 802.11  ESSID:"****"
          Mode:Managed  Frequency:2.447 GHz  Access Point: 
          Bit Rate=1 Mb/s   Tx-Power=20 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-40 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:70   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    600    0        0 wlp58s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlp58s0
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp58s0

##### resolv.conf #######################

nameserver 127.0.0.1

##### network managers ##################

Installed:

    NetworkManager

Running:

root       834     1  0 10:14 ?        00:00:07 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         wlp58s0
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Qualcomm Atheros
GENERAL.PRODUCT:                        QCA6174 802.11ac Wireless Network Adapter
GENERAL.DRIVER:                         ath10k_pci
GENERAL.DRIVER-VERSION:                 4.13.0-16-generic
GENERAL.FIRMWARE-VERSION:               WLAN.RM.4.4-00022-QCARMSWPZ-2
GENERAL.HWADDR:                         
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.4/0000:3a:00.0/net/wlp58s0
GENERAL.IP-IFACE:                       wlp58s0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     ****
GENERAL.CON-UUID:                       ****
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/7
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     1 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
CAPABILITIES.SRIOV:                     no
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   yes
IP4.ADDRESS[1]:                         192.168.1.49/24
IP4.GATEWAY:                            192.168.1.254
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             192.168.1.254
DHCP4.OPTION[1]:                        requested_routers = 1
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_time_offset = 1
DHCP4.OPTION[4]:                        requested_domain_name = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_broadcast_address = 1
DHCP4.OPTION[7]:                        requested_netbios_scope = 1
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        next_server = 0.0.0.0
DHCP4.OPTION[10]:                       expiry = 1508710174
DHCP4.OPTION[11]:                       requested_interface_mtu = 1
DHCP4.OPTION[12]:                       requested_subnet_mask = 1
DHCP4.OPTION[13]:                       routers = 192.168.1.254
DHCP4.OPTION[14]:                       dhcp_message_type = 5
DHCP4.OPTION[15]:                       ip_address = 192.168.1.49
DHCP4.OPTION[16]:                       broadcast_address = 192.168.1.255
DHCP4.OPTION[17]:                       requested_static_routes = 1
DHCP4.OPTION[18]:                       requested_domain_name_servers = 1
DHCP4.OPTION[19]:                       requested_ntp_servers = 1
DHCP4.OPTION[20]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[21]:                       dhcp_lease_time = 43200
DHCP4.OPTION[22]:                       domain_name_servers = 192.168.1.254
DHCP4.OPTION[23]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[24]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[25]:                       network_number = 192.168.1.0
DHCP4.OPTION[26]:                       requested_host_name = 1
DHCP4.OPTION[27]:                       dhcp_server_identifier = 192.168.1.254
IP6.ADDRESS[1]:                         ****/64
IP6.ADDRESS[2]:                         ****/64
IP6.ADDRESS[3]:                         ****/64
IP6.GATEWAY:                            ****
IP6.ROUTE[1]:                           dst = ****::/64, nh = ::, mt = 600
IP6.DNS[1]:                             ****
IP6.DNS[2]:                             ****

SSID                      BSSID              MODE    CHAN  FREQ      RATE       SIGNAL  BARS  SECURITY     ACTIVE  *
**HIDDEN FOR PRIVACY**

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

##### NetworkManager profiles ###########
** HIDDEN FOR PRIVACY **

##### iw reg get ########################



global
country 00: DFS-UNSET
    (2402 - 2472 @ 40), (N/A, 20), (N/A)
    (2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, NO-IR
    (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
    (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, NO-IR
    (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, NO-IR
    (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
    (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
    (57240 - 63720 @ 2160), (N/A, 0), (N/A)

##### iwlist channels ###################

lo        no frequency information.

wlp58s0   32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz
          Current Frequency:2.447 GHz (Channel 8)

##### iwlist scan #######################

lo        Interface doesn't support scanning.

wlp58s0   Interface doesn't support scanning : Device or resource busy

##### module infos ######################

[ath10k_pci]
filename:       /lib/modules/4.13.0-16-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
firmware:       ath10k/QCA9377/hw1.0/board.bin
firmware:       ath10k/QCA9377/hw1.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/board-2.bin
firmware:       ath10k/QCA6174/hw3.0/board.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-6.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-4.bin
firmware:       ath10k/QCA6174/hw2.1/board-2.bin
firmware:       ath10k/QCA6174/hw2.1/board.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-5.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-4.bin
firmware:       ath10k/QCA9887/hw1.0/board-2.bin
firmware:       ath10k/QCA9887/hw1.0/board.bin
firmware:       ath10k/QCA9887/hw1.0/firmware-5.bin
firmware:       ath10k/QCA988X/hw2.0/board-2.bin
firmware:       ath10k/QCA988X/hw2.0/board.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-5.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-4.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-3.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-2.bin
license:        Dual BSD/GPL
description:    Driver support for Qualcomm Atheros 802.11ac WLAN PCIe/AHB devices
author:         Qualcomm Atheros
srcversion:     8D7A52EE462CD73D0445DB2
depends:        ath10k_core
intree:         Y
name:           ath10k_pci
vermagic:       4.13.0-16-generic SMP mod_unload
signat:         PKCS#7
signer:
sig_key:
sig_hashalgo:   md4
parm:           irq_mode:0: auto, 1: legacy, 2: msi (default: 0) (uint)
parm:           reset_mode:0: auto, 1: warm only (default: 0) (uint)

[ath10k_core]
filename:       /lib/modules/4.13.0-16-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_core.ko
license:        Dual BSD/GPL
description:    Core module for Qualcomm Atheros 802.11ac wireless LAN cards.
author:         Qualcomm Atheros
srcversion:     7F06478F5745B064BF3BC89
depends:        mac80211,cfg80211,ath
intree:         Y
name:           ath10k_core
vermagic:       4.13.0-16-generic SMP mod_unload
signat:         PKCS#7
signer:
sig_key:
sig_hashalgo:   md4
parm:           debug_mask:Debugging mask (uint)
parm:           uart_print:Uart target debugging (bool)
parm:           skip_otp:Skip otp failure for calibration in testmode (bool)
parm:           cryptmode:Crypto mode: 0-hardware, 1-software (uint)
parm:           rawmode:Use raw 802.11 frame datapath (bool)

[ath]
filename:       /lib/modules/4.13.0-16-generic/kernel/drivers/net/wireless/ath/ath.ko
license:        Dual BSD/GPL
description:    Shared library for Atheros wireless LAN cards.
author:         Atheros Communications
srcversion:     555BBBB9D4FCA58A05E7C0D
depends:        cfg80211
intree:         Y
name:           ath
vermagic:       4.13.0-16-generic SMP mod_unload
signat:         PKCS#7
signer:
sig_key:
sig_hashalgo:   md4

[mac80211]
filename:       /lib/modules/4.13.0-16-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     66E288B8743878C5423A01E
depends:        cfg80211
intree:         Y
name:           mac80211
vermagic:       4.13.0-16-generic SMP mod_unload
signat:         PKCS#7
signer:
sig_key:
sig_hashalgo:   md4
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/4.13.0-16-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     A854863B536C70273DE73A5
depends:
intree:         Y
name:           cfg80211
vermagic:       4.13.0-16-generic SMP mod_unload
signat:         PKCS#7
signer:
sig_key:
sig_hashalgo:   md4
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[ath10k_pci]
irq_mode: 0
reset_mode: 0

[ath10k_core]
cryptmode: 0
debug_mask: 0
rawmode: N
skip_otp: N
uart_print: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

grep: /etc/rc.local: No such file or directory

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[ 2518.493849] wlp58s0: send auth to  (try 1/3)
[ 2518.498139] wlp58s0: authenticated
[ 2518.510661] wlp58s0: associate with  (try 1/3)
[ 2518.514808] wlp58s0: RX AssocResp from  (capab=0x411 status=0 aid=1)
[ 2518.517910] wlp58s0: associated
[ 2518.518031] IPv6: ADDRCONF(NETDEV_CHANGE): wlp58s0: link becomes ready
[ 3790.657597] wlp58s0: deauthenticating from  by local choice (Reason: 3=DEAUTH_LEAVING)
[ 3790.691224] wlp58s0: authenticate with 
[ 3790.744676] wlp58s0: send auth to  (try 1/3)
[ 3791.745320] wlp58s0: send auth to  (try 2/3)
[ 3792.702724] wlp58s0: authenticated
[ 3792.705567] wlp58s0: associate with  (try 1/3)
[ 3792.708886] wlp58s0: RX AssocResp from  (capab=0x411 status=0 aid=1)
[ 3792.712592] wlp58s0: associated
[ 4892.860736] wlp58s0: deauthenticating from  by local choice (Reason: 3=DEAUTH_LEAVING)
[ 4896.836038] wlp58s0: authenticate with 
[ 4896.888893] wlp58s0: send auth to  (try 1/3)
[ 4896.890516] wlp58s0: authenticated
[ 4896.892901] wlp58s0: associate with  (try 1/3)
[ 4896.897903] wlp58s0: RX AssocResp from  (capab=0x411 status=0 aid=1)
[ 4896.900310] wlp58s0: associated

########## wireless info END ############

Edit: The solution provided by Zsolt Rizsányi works, alternatively I choose to change my WiFi card by an Intel 8265 which have a better range and a better support of the 5G frequency.

  • @DavidFoerster Thanks for pointing this out, I've edited the question with the result. – luxcem Oct 22 '17 at 15:49
  • The system log indicates that the wireless connection was dissociated from the access point deliberately. I don't have a specific recommendation aside from various driver module options suggested in answers to other questions about the unstable connections with the same WiFi module. See askubuntu.com/…. – David Foerster Oct 22 '17 at 18:50
  • Yes like I said I have to disconnect / reconnect every 10 minutes. – luxcem Oct 23 '17 at 13:02
  • 1
    Have the same issue on an Asus UX303LA laptop. It's a clean install but ran 17.04 as well previously without any problems. – Attila Fulop Oct 23 '17 at 15:58
  • 1
    This is not a duplicate. – dpn Nov 6 '17 at 5:28
up vote 10 down vote accepted

I had the same issue and found a Debian bug report that also has a solution. See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=879184

The solution is simple: install updated firmware from firmware repository provided by Qualcomm.

Detailed steps:

  1. Download https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/board-2.bin and overwrite /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin with the downloaded file.

  2. Download https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/4.4.1/firmware-6.bin_WLAN.RM.4.4.1-00065-QCARMSWP-1 and overwrite /lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin.

  3. Restart

  • This solution worked for me. The only problem is the UI can show "?" for the connection for a few minutes even if the connection is working fine. – Fritzy Dec 8 '17 at 22:31
  • For point 2., which is the final name of that file: firmware-6.bin_WLAN.RM.4.4.1-00065-QCARMSWP-1 or firmware-6.bin? – ROMANIA_engineer Dec 26 '17 at 0:36
  • firmware-6.bin (there is already a file with that name, you need to overwrite it) – Zsolt Rizsányi Dec 27 '17 at 20:49
  • 2
    This also happens now that Ubuntu 16.04 has the 4.13 kernel and linux-firmware 1.157.14. – andrebrait Jan 15 at 1:43
  • 1
    Guys, those of you who are affected, please report that you're also affected here: bugs.launchpad.net/bugs/1743279 – andrebrait Jan 15 at 12:21

This bug has been reported on launchpad: https://bugs.launchpad.net/bugs/1743279 If you're affected, please tell them in the bug report so they can fix the bug ASAP.

The firmware-6.bin file needs to be updated. Ubuntu currently ships version WLAN.RM.4.4-00022-QCARMSWPZ-2 and the fix for this issue was released in version WLAN.RM.4.4.1-00051-QCARMSWP-1, which means you need some version later than the latter for the card to work properly on >4.12 kernels.

As of today, this bug can be fixed by simply replacing the board-2.bin (not actually required but recommended) and firmware-6.bin files with what's currently in the upstream repository for linux-firmware, or by grabbing the firmware-6.bin from kvalo's repository for the proper version.

You can grab the correct version from kvalo's repository, which is guaranteed to always work (if you don't require the new board-2.bin as well).

These commands below will automate the replacement of the files:

$ sudo wget https://github.com/kvalo/ath10k-firmware/raw/master/QCA6174/hw3.0/4.4.1/firmware-6.bin_WLAN.RM.4.4.1-00051-QCARMSWP-1 -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin

Alternatively, you can grab the files from the current state of linux-firmware These commands below will automate the replacement of the files from what's upstream (notice these commands might work now but there's no guarantee they will work in the future because the repository's contents can change, although they will hardly ever break things like this).

$ sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA6174/hw3.0/board-2.bin -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin
$ sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA6174/hw3.0/firmware-6.bin -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin

Then reboot.

  • 1
    I have this card in my laptop but don't use it. Still +1 for your research improving the overall environment in case I use it some day. – WinEunuuchs2Unix Jan 16 at 4:17
  • 1
    @WinEunuuchs2Unix thanks. If you happen to be affected by it someday please report it in the bug report I've linked here. – andrebrait Jan 16 at 11:04
  • 1
    I subscribed to the bug report and recorded as being affected as I have noticed WiFi reconnecting from time to time on Kernel 4.14. But as I mentioned I'm teethered to the good old blue wire. – WinEunuuchs2Unix Jan 16 at 11:15
  • I see the bug fix has been pushed into proposed 16.04 and 17.10. Is it time to update this answer? – WinEunuuchs2Unix Jan 26 at 14:44
  • 1
    Yes, it will. Notice that this bug was fixed in version 1.157.16 or the package on Xenial and 1.169.3 in Artful. – andrebrait Feb 8 at 8:37

EDIT: The correct fix for this is to install the drivers manually and not change your wifi config on your network. At least until newer drivers are included in ubuntu.

A change to my wifi routers fixed this, I'm not sure if the APs or linux kernel/drivers are to blame here.

On OpenWrt/LEDA, option wpa_group_rekey '0'

Needs to be added to the wireless "wifi-iface" configs. There is no option within the web config interface.

UPDATE: I set this to 3600 and the same issue happened again, I'm assuming there is a negotiation not taking place between the client and WAP. Still probably a Linux/driver bug. I set this to 3600 instead of 0 since it's theoretically more secure but no go, i'm assuming zero means it doesn't regenerate a key.

  • This is a known bug that's been fixed upstream, but I opened a bug report on launchpad too: bugs.launchpad.net/bugs/1743279 please contribute there reporting you're also affected. – andrebrait Jan 15 at 12:22

A fix has been released in the linux-firmware package (version 1.169.3 in 17.10 and version 1.157.16 in 16.04). Open a terminal (press Ctrl+Alt+T), and run the following:

sudo apt update
sudo apt upgrade

I was with the same problem. Here how i resolve the problem: https://ubuntuforums.org/showthread.php?t=2261225

Go to your modem wifi security settings.

If WPA/WPA2 Group Key Update Period is zero or disabled, you must change it.

Set WPA/WPA2 Group Key Update Period to 86400 as shown in the screenshot.

Save your settings and reboot your modem/router.

enter image description here

  • 1
    Indeed, but I rather want the driver to handle group key update correctly. – luxcem Oct 26 '17 at 13:07
  • It's not possible to change this setting on apple airports express :( – dpn Nov 16 '17 at 9:50
  • Guys, those of you who are affected, please report that you're also affected here: bugs.launchpad.net/bugs/1743279 – andrebrait Jan 17 at 2:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.