13

How can I get the Workrave indicator to show in Ubuntu 17.10? Version 1.10 supposedly has GNOME Shell support.

13

It took some time to figure this out for me, too...

First, you'll need gnome-tweak-tool for being able to enable this.

sudo apt install gnome-tweak-tool

Second, the Workrave package in the official repo is badly packaged (it brings down some XFCE dependencies that mess up your Gnome session), so you'll have to install the workrave-gnome package from Rob Caeler's PPA.

sudo add-apt-repository -u ppa:rob-caelers/workrave

Now you can do:

sudo apt install workrave-gnome
  • Now fire up Workrave. It will show up in a small window with all the timers running -- no applet yet.

  • Then fire up gnome-tweak-tool, head to Extensions, and enable Workrave.

Now the applet (and/or the tray icon, if you're using it) should be visible in the top panel.

One more thing I've noticed on my machine is that Workrave segfaults under Wayland, so you will probably have to login into xorg if you want to use Workrave.

6

I was getting segfaults also but managed to get it to work by specifying the X window:

workrave --display=:0

To fix it permanently:

cp /usr/share/applications/workrave.desktop ~/.local/share/applications/

And then edit the "Exec" command in ~/.local/share/applications/workrave.desktop

  • An interesting observation though. Mine was only crashing when prime-select was set to intel. It didn't crash under my nvidia drivers. – kgx Nov 7 '17 at 16:54
3

For Ubuntu 18.04, just install "GNOME Tweaks" and in Extensions tab, turn on Workrave notification.

screenshot

  • i don't have 'Workrave' extension in 18.04. – atti Aug 7 '18 at 17:54
  • 2
    @atti reinstall workrave and reboot. Maybe help! – Reza Aug 7 '18 at 18:14
  • handling of GNOME Shell extensions has changed, see askubuntu.com/questions/75530/… – törzsmókus Mar 5 at 9:17
1

Another option is to add command workrave --display=:0 to Startup Applications.

Not sure why, but copying workrave.desktop file to ~/.local/share/applications/ and modifying it didn't work for me but Startup Applications did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.