1

This worked fine on 17.04:

sudo mount -v -t cifs -o username=myname,password=mypassword //nas/share /mnt/nas

Now on 17.10 it gives me:

mount.cifs kernel mount options: ip=192.168.1.150,unc=\\nas\share,user=myname,pass=********
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

A singularly unhelpful error message, given that the manpage hasn't changed. I can't figure out how to increase the verbosity of the error message beyond the above. How do I persuade mount.cifs to tell me what it doesn't like?

1
  • 1
    Don't mix question and answer, so it may confound someone looks for a full-reported solution to this issue. You must separate question and answer, each one in appropriate section.
    – Redbob
    Oct 21 '17 at 16:14
5

Never mind. Solved.

"cifs troubleshooting" turned out to be the magic words for Google, rather than "mount verbosity" etc.

# modprobe cifs
# echo 7 > /proc/fs/cifs/cifsFYI
# mount... etc.
# dmesg

Gave me:

CIFS VFS: Dialect not supported by server. Consider specifying
vers=1.0 or vers=2.1 on mount for accessing older servers

And adding "vers=2.1" to the options fixed it.

0
5

After doing a modprobe / dmesg, I got this message:

No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

Thus it worked adding the "vers=1.0" to the options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.