5

I have been running 17.04 with the amdgpu driver. After upgrading to 17.10, it boots to a deep purple (blank) screen. I have whole disk encryption, so it would normally show a password prompt at this point.

The graphics card is Radeon R9 290X.

When resetting the computer, it boots to the GRUB menu, and I've tried different options:

  • Kernel 4.10.0-37 works, but stops before the boot process finishes (Starting GNOME). No graphics or login prompt.
  • Kernel 4.13.0-16 in recovery mode takes me to the recovery menu.
    • Resume: Prompts for a password for my drives. It times out before I can enter all the passwords*, and it takes me back to the recovery menu. Resume again gives a blank screen. If I first drop to root shell and do systemctl start dev-mapper-pool, then enter passwords, then exit the shell and choose resume, I can get to a basic desktop with low graphics. I can log in,etc,. This is a huge improvement for me!
    • failsafeX: Boots to the oh so familiar low graphics screen, but none of the options help me.
    • root shell: This works. I can also remount read-write. I uninstalled some AMDGPU-PRO packages I had for OpenCL support, but it doesn't make a difference.

I have got this purple screen before, but it's usually fixed in a matter of uninstalling some AMD driver I've tried. Now, I can't see what to do..

*I have the same PW on all drives, and normally it only prompts once for the PW, now it asks for each drive.

2

Uninstall radeon using the command

amdgpu-pro-uninstall

It worked for me. Then type

reboot
  • 1
    Sorry it took so long to check this out, and thanks for sharing. It works to bring me graphics. After this, I can even install amdgpu-pro 17.40 again with the --compute, as in this guide math.dartmouth.edu/~sarunas/amdgpu.html . I'll mark this as a solution since everything is working now. – Marius Bjørnstad Dec 6 '17 at 19:52
1

I just had a similar problem with Debian and my R5/230 adapter; in this case the DVI adapter was not recognised, it only accepted VGA @ 1266 instead of DVI @ 1920

This link brought me to the right place on the AMD support website https://help.ubuntu.com/community/BinaryDriverHowto/AMD and http://support.amd.com/en-us/download

Also maybe interesting for you https://wiki.ubuntuusers.de/Grafikkarten/AMD/radeon/

  • Thanks for the response, I will try to get the AMDGPU-PRO installed again. I used to have some AMDGPU-PRO components on 17.04 thanks to this page math.dartmouth.edu/~sarunas/amdgpu.html . I am using a Displayport to HDMI 2.0 dongle, but I also tried with a DVI monitor. Don't think I have a VGA out. – Marius Bjørnstad Oct 26 '17 at 18:49
1

My issue was this line

blacklist radeon

in /etc/modprobe.d/blacklist-radeon.conf. This was probably done by me, but not 100% sure.

Starting from live USB worked right away, and I could also boot when I removed the blacklist command. However, it used the radeon driver, not the amdgpu driver. Both drivers were loaded.

This link showed how to start with amdgpu driver: https://forum.manjaro.org/t/solved-kernel-4-13-doesnt-boot-with-amdgpu/30770/13 . Adding this to the kernel command line:

radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1

The GUI didn't work for me when using this command line, except for the password prompt and console at boot. OpenCL works, so I choose to use this for now.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.