25

I recently upgraded from 17.04 to 17.10.

The GNOME Calendar application displays a popup requesting my password for my linked Google account.

It does so whenever launched explicitly, and at times on its own.

When I type my (correct) password, the popup just reappears as if the password wasn't incorrect.

The only way to dismiss the popup is to press the Cancel button.

I can see my Gmail events in the calendar, so it does seem to sync.

I tried removing my Google account from Settings -> Online accounts and re-adding it, with no change.

If it's any help, I am using Google's two-factor authentication.

Also note that Thunderbird does not seem to have this issue.

  • 1
    I have seen someone that had multiple google keyrings for some reason. Thus he had to repeatedly enter his password; once for each keyring. – ravery Oct 21 '17 at 9:41
  • @ravery any clue on how I would find out if that is my issue? – Mena Oct 21 '17 at 10:07
  • @ravery nevermind, I just launched the Passwords and Keys client, and there is only one entry listed for Google. – Mena Oct 21 '17 at 10:10
  • I'm experiencing this as well as of upgrading today. – skeevey Oct 22 '17 at 19:37
  • 3
    I filled a bug in launchpad bugs.launchpad.net/ubuntu/+source/gnome-calendar/+bug/1726922 please if the description somehow matches your problem please mark it as affects me. – Andrés Alcarraz Oct 24 '17 at 16:00
25

I was having the same problem and resolve it by deleting the configuration files of Evolution. Do this:

rm -rf ./.config/goa-1.0/accounts.conf
rm -rf ./.config/evolution
rm -rf ./.local/share/evolution

I don't have that problem anymore since I did that. I hope this could help you.

  • 7
    It would appear that removing "./.config/evolution" is sufficient to fix this. It is recreated on a restart and I don't have the problem now. – Terry Dixon Nov 21 '17 at 22:21
  • Worked for me! Had to login into the account again and it tried to ask me multiple times, but logging in once and closing the other Google windows worked fine. – dr mat Jan 7 '18 at 8:46
  • I recently had to upgrade again, since no fixes are delivered to 17.04 anymore, and tried Terry Dixon's variant of this solution. Works for me, thanks. – Mena Jan 26 '18 at 17:18
  • 1
    Worked for me. No need to remove the third element for me – Snorky35 Mar 29 '18 at 10:57
  • 1
    Using the commands rm -rf ./.config/goa-1.0/accounts.conf, rm -rf ./.config/evolution, rm -rf ./.local/share/evolution would remove all your account, local emails and configuration files. If you do not intent to lose all your downloaded emails then do not use the above commands. Do correct me if I am wrong. – Vigyani Jun 8 at 11:39
2

Sorry to hear you had to revert @Mena. I had the same upgrade path and ran into this as well. Hopefully the below will be helpful for someone else who finds this.

What I found is that the Online Accounts feature isn't fully compatible with Google's TFA. The following is a workaround, to be entered when prompted for a password:
Enter an application specific password for Google in one of the recurring password prompts. Since setting an application specific password, it hasn't bugged me again, even after several reboots and my calendar was syncing before reboot. However for it to sync again- you have to manually bring up the calendar on each reboot, and when it prompts again for password - re-enter the app specific password.

To get the app specific password - go to Google's App password page and generate one to use with Ubuntu's Online Accts (and save it in your favorite password manager for use again later): https://security.google.com/settings/security/apppasswords

For more reading on Google TFA and application compatibility, here's Google's help page on the matter: https://support.google.com/accounts/answer/185833?hl=en

Screencap from me setting an app specific password in Google: Screencap for where I gen'd an app password for this

  • Hi Jeff, I don't know where to put that password since the calendar already has my account set up and working, the problem is that it asks for the password despite that. And it does also with an account that doesn't have TFA. – Andrés Alcarraz Oct 30 '17 at 3:36
  • I'll update my answer in the morning when pull the laptop back up.. You can edit the login used in account settings. – Jeff Burns Oct 30 '17 at 3:38
  • Iknow that but the configured accounts are working.. I think the problem is some remanent account frombthe previous installation that don't show in the online accounts page.As I said – Andrés Alcarraz Oct 30 '17 at 12:03
  • @AndrésAlcarraz and you're using an app specific password on the TFA enabled Google account? Until I did that, my calendar sync would work for a little bit, and then I'd be getting prompted for password again. – Jeff Burns Oct 30 '17 at 12:58
  • I didn't, when I set up the account in online accounts it asked me for the TPA step, i.e. I had to authorize the login from my phone, I guess we are facing two different bugs, either way I will do what you suggest in your answer but I don't think that's gonna work since in the account not using TPA the problem is the same, it asks for my password again and again – Andrés Alcarraz Oct 30 '17 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.