10

I recently shifted to Ubuntu 17.10. After enabling ubuntu-dock extension from Gnome-Tweak-Tools, I found no specific settings for customizing the Ubuntu-Dock in gnome-settings or gnome-control-center. A temporary hack i found for accessing the dock settings was changing XDG_CURRENT_DESKTOP variable from terminal and then launching gnome-control-center from there.

XDG_CURRENT_DESKTOP=ubuntu:GNOME gnome-control-center

I wanted to know if there is some permanent way to get Ubuntu-Dock-Settings in gnome-control-center

  • Did you upgrade from Ubuntu GNOME 17.04? – pomsky Oct 21 '17 at 8:19
  • yes, but I had upgraded to ubuntu 17.04 from 16.04 only some mins before that – pearlstar Oct 21 '17 at 8:21
11

If you have upgraded from Ubuntu GNOME 17.04 the default GNOME session(s) will still remain for you to choose during login. On top of that the all-new GNOME session(s) customised by Ubuntu (simply named Ubuntu and/or Ubuntu on Xorg) will be added.

Ubuntu dock setting is accessible only from the GNOME session(s) customised by Ubuntu, not from the default GNOME session(s).

When you boot your system and get to the GDM login screen you should find a cogwheel (⚙️) next to the sign in button. If you click on the cogwheel you should find an Ubuntu (and/or Ubuntu on Xorg) option.

Choose Ubuntu (or Ubuntu on Xorg) instead of GNOME (or GNOME on Xorg).


See this if you don't have Ubuntu Dock installed in the first place: Dock settings missing in gnome-control-center after upgrade to Ubuntu 17.10

  • I encountered similar issues. I upgraded from 17.04. But in my case there is no Ubuntu option in the GDM login screen. I am confused about that. – funicorn Nov 4 '17 at 6:37
  • 1
    I actually upgraded first from 16.04 to 17.04, then to 17.10. Before step 1, I already had unity removed and gnome-shell installed--It may be the key that caused the non-standard consequence. It is possible that some xsession files like ubuntu:GNOME.desktop (NOT gnome.desktop itself) is missing from the present system. As a result the standard ubuntu session cannot be started via GDM, and the system can only run the 'pure' gnome desktop. – funicorn Nov 4 '17 at 13:44
  • @funicorn I think you should create a new Q&A with your issue and solution. I believe your situation doesn't apply to this question as OP here has "Ubuntu" session(s) along with "GNOME" session(s). They were just confused as they got logged into a GNOME session by default. But in your case the "Ubuntu" sessions were missing altogether. – pomsky Nov 4 '17 at 13:51
  • 1
    Thank you! This turned out to be my problem for missing dock, after neither askubuntu.com/questions/1141537/no-dock-in-ubuntu-18-04 nor askubuntu.com/questions/1128506/… were of any help. – Jimmy He Oct 15 at 21:40
0

I suggest you check whether following packages are installed in your system:

ubuntu-session, ubuntu-settings, ubuntu-gnome-default-settings, ubuntu-standard

After I installed these packages and rebooted, Ubuntu login option appears in the GDM chooser. Once running with that option, gnome add the dock item to the gnome-control-center. I don't know which packages make this happen. But it works for me.

0

I just had the same issue with gnome-control-center, after doing a minimal (re-)installation of Gnome 3 on Ubuntu 17.10.

I my case the solution was to install gnome-shell-extension-ubuntu-dock.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.