2

In some website, when I have to enter my e-mail address, I have to use the AltGr key to print the at symbol. The problem is, on some websites, when I push on AltGr, it selects all the content of the field. Therefore, when I push on @, all my text is deleted and replace by the at symbol.

It's really annoying because I have to use copy-paste tip or start by the at when I enter my e-mail address.

How can I solve this problem?

  • I have exact the same issue! – Adam Nov 9 '17 at 22:38
  • I created a bug report just now: bugzilla.mozilla.org/show_bug.cgi?id=1416046 – Adam Nov 9 '17 at 23:42
  • Thanks but it's weird, it doesn't happen in every website. I can't reproduce it in every case. – Pierre Nov 10 '17 at 17:52
  • Can you tell me a website where you can't reproduce it? It happens to me always, aslong as I enter the field with tab key. – Adam Nov 10 '17 at 17:56
  • It's weird because I guess this issue is solved on my computer. When I wrote this question, I had this problem on this website : edumoov.com/users/register Now, it works well. What happen to you if you try to reproduce it on this website? – Pierre Nov 11 '17 at 10:08
1

The permanent Workaround is to select input method "None" in system option ▸ languages ▸ Keyboard Input system.

This does not have a negative impact if you don't need interactive keyboard input like it is necessary for chinese and other scripts.

Source: longstanding unity bug report https://bugs.launchpad.net/unity/+bug/1484157

| improve this answer | |
  • It doesn't work. – Pierre Sep 10 '18 at 17:28
  • Perfect, worked for me! I had an issue where when entering the @ symbol in the Thunderbird email address input field (AltGr+Q on a German keyboard), the entire field's contents were selected, thus removing everything else in the field after the next key press. Note that you have to logout+login (or reboot) to make the fix work. – sigalor May 20 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.