Trackpad two finger scrolling and right-click issue with Ubuntu 17.10 (i386, 64bit, GNOME 3.26.1) on a Lenovo T540p (the model with a Intel Core i5-4210M Haswell CPU etc)

  • What is the question? I only see a statement. – Rinzwind Oct 21 '17 at 20:13
  • 1
    This affected my ThinkPad X250 also on 17.10. The answer of @hpotter40 below worked for me. – Majal Nov 2 '17 at 0:51

I have the same issue on my Thinkpad T450s. This issue is referenced on launchpad here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1722478

It seems to happen after a resume. The workaround described on LP1722478 works for me:

sudo modprobe -r psmouse
sudo modprobe psmouse

Update for other ThinkPad users, as per the hard work done here, the workaround is as follows...

Edit the file /etc/default/grub and change the line:



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=0"


sudo update-grub

and reboot.

  • 1
    Awesome! Nicer than the modprobe solution IMO since that also requires adding the modprobe commands in the resume in pm-utils. – Chester Oct 14 '18 at 0:05

I guess I know what you mean. If you install Gnome Tweaking Tool, a.k.a. Tweaks, you can go to Keyboard & Mouse > Click Method > Fingers. That might solve it.


About the two finger scrolling, try with three fingers, that worked out of the box for me on my Lenovo X1 Carbon 2015.

  • Same here, using Ubuntu 19.10 on a Lenovo ThinkPad T440s. As mentioned in LP #1722478, this behavior is part of the bug and not intended. – tanius Apr 10 '19 at 18:01

I had the same problem. In Gnome Tweaks, 'Keyboard & Mouse' settings, changing the click method to 'Areas' got the right-click working again.


As mentioned in the answer by @hpotter40, this is behavior is bug LP #1722478. It affects a wide variety of relatively recent ThinkPad computers, and is still present in Ubtuntu 19.04. Three workarounds are discussed in the Launchpad issue. One is mentioned by @hpotter40 in his answer, the other two are here:

Option 1: Switch off Intertouch

This is my favourite, as it is the simplest to configure.

  1. Edit file /etc/default/grub and change the line


    into this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=0"
  2. Execute:

    sudo update-grub
  3. Reboot.

Source: from here and here. Also I just saw it's covered already in another answer here.

Option 2: i2c-801 module

  1. If your /etc/modprobe.d/blacklist.conf contains a line blacklist i2c_i801, remove it or make it into a comment.

  2. Use this technique to reload the i2c-i801 module after each resume from suspended state. You can of course also do that manually, in which case the commands are:

    sudo modprobe -r i2c-i801
    sudo modprobe i2c-i801

There is no need to modprobe this module at system start explicitly, as two-finger scrolling and two-finger-tap for right-clicking only breaks at the first resume from suspended state.

Source: from here.


You probably were using Unity as your desktop environment before and are using Gnome Shell now. (Whether you wanted it or not, the upgrade decided for you.)

If you want to use Unity even now, that is an option, and it will resolve your problem. You may already have Unity installed, whether you know it or not, but in case you don't:

sudo apt install unity

Then when you restart and select your user on the login screen, don't enter your password right away. Instead, notice the little gear icon by your 'Sign in' button. Click it, and you should see that you have a choice between 'Ubuntu', 'Ubuntu on Xorg', and 'Unity'. Click 'Unity', then sign in with your password as usual.

I recommend this for users who want to go back to the environment they had before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.