9

Been running Ubuntu 17.10 since beta 2. Suddenly today, every time firefox closes an audio stream, the application volume in Pulse is set to zero. This happens, for example, when switching from one youtube video to another.

I've tried many things. Here's what I remember:

  • checked no such problem in chrome or other audio applications
  • setting firefox's media:default_volume
  • verified pulse's flat_volumes is no
  • rm -rf .config/pulse; pulseaudio -k
  • firefox "safe mode"
  • firefox reset

5 Answers 5

9

I ran into the same problem the other day. It was only affecting YouTube and not other websites. I found there is a volume icon on the window tab on top that suggested that somehow the YouTube tab is muted. Clicking on the muted volume icon, I was able to get sound to work properly after reload. Hope this help others to solve this problem.

3
  • 2
    +1 because this seemingly obvious answer is actually not obvious at all - given that the audio volume keeps going to zero in pulse, from where it can be turned up again, it is not at all obvious that it's Youtube that's doing this. The fact that a website can affect a slider bar in pulse was news to me. Less obvious still if you haven't recently used any other websites that have sound.
    – Rodney
    Nov 5, 2020 at 21:13
  • 1
    @Rodney and thanks for your clarifying comment … otherwise I would have overlooked the solution.
    – lxg
    Jul 8, 2021 at 6:43
  • 1
    Awesome!!! This is very, VERY counterintuitive.
    – Leonardo
    Oct 12, 2021 at 19:07
4

After living with it for several days, I deleted my Firefox profile: ~/.mozilla and started over. Problem solved, the Microsoft™ way!

source

3
  • I have the same problem and tried most of the solutions you listed in your first post without success. What profile did you delete to make it work ? Dec 30, 2017 at 17:02
  • support.mozilla.org/en-US/kb/…
    – Autumn
    Dec 31, 2017 at 17:08
  • Worked for me too. Deleted the whole ~/.mozilla folder. It's a bit radical but with firefox sync recovering all settings it's not too painful. Thanks. Jan 3, 2018 at 15:27
1

In case someone comes across this question, below is the solution I provided in another post (based on the solution given in Inconsistent Sound Volume Ubuntu 20.04, which deserves credit).

Basically, you need to change flat-volumes = no to flat-volumes = yes. The values "true", "1" and "on" are equivalent to "yes", according to the manpage (https://manpages.ubuntu.com/manpages/focal/man5/pulse-daemon.conf.5.html):

For the settings that take a boolean argument the values true, yes, on and 1 are equivalent, resp. false, no, off, 0.

Don't forged to uncomment the respective line by removing the ";" or "#":

The configuration file is a simple collection of variable declarations. If the configuration file parser encounters either ; or # > it ignores the rest of the line until its end.

The configuration file is: /etc/pulse/daemon.conf

Other possible locations are: ~/.config/pulse/daemon.conf, ~/.config/pulse/daemon.conf.d/.conf and /etc/pulse/daemon.conf.d/.conf:

The PulseAudio sound server reads configuration directives from a configuration file on startup. If the per-user file ~/.config/pulse/daemon.conf exists, it is used, otherwise the system configuration file /etc/pulse/daemon.conf is used. In addition to those main files, configuration directives can also be put in files under directories ~/.config/pulse/daemon.conf.d/ and /etc/pulse/daemon.conf.d/.

According to the aforementioned post, rebooting is necessary for the change to take effect.

About the configuration option:

flat-volumes= Enable 'flat' volumes, i.e. where possible let the sink volume equal the maximum of the volumes of the inputs connected to it. Takes a boolean argument, defaults to no.

1
1

I just had the very same issue and after some tinkering found it was the 'block audio/video' option responsible. It was set to block audio only, which resulted in video playing but volume being set to 0. Setting it to allow audio and video using the menu next to the padlock in the URL bar fixed it for me. Must have bumped it by accident.

1

Instead of clearing my entire firefox profile, I found that clearing the cookies and site data for the one site that was resetting the volume to 0 worked just fine:

  1. Click the lock icon just before URL address (must be on the problem site)
  2. Click "Clear cookies and site data ..."
  3. Click the "Remove" button
  4. No restart needed, but needed to log in to the site again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.