4

I don't see the gear button next to the Sign in button at the login screen. I have Nvidia drivers installed (for Nvidia 730 GT card). Ubuntu boots into Xorg as seen from the terminal with echo $XDG_SESSION_TYPE which outputs x11.

How do I switch to Wayland?

  • Thanks, I did read on Didier Rocks that Wayland is disabled and falls back by default when proprietary Nvidia drivers are used. – surya_hs Oct 22 '17 at 6:58
3

That means Wayland is disabled by your hardware. Try switching to nouveau to get Wayland working.

You might face this issue once you do it: GNOME has grey bar on top and bottom after upgrade from 17.04 to 17.10, how do I fix it to how it's supposed to look?

2

That means Wayland is disabled by your hardware.

Thanks, I did read on Didier Rocks that Wayland is disabled and falls back by default when proprietary Nvidia drivers are used. – user299070 yesterday

I am not a huge fan of the Linux Nvidia drivers*, but once in a while I try them to check the performance of the machine. More often than not, I end up in a console and no X/Wayland.

I have seen some Ubuntu users reinstalling their machine after this f* up, so here's how to fix it (I always forget the initramfs step and end up wasting a lot of time):

$ sudo apt-get remove --purge nvidia-*
$ sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf_pre-nvidia
$ sudo update-initramfs -u
$ reboot
  • 1
    This works absolutely flawlessly. Thank you! The correct answer is what you are saying: nvidia messes up wayland and ubuntu disables wayland and offer only X11. – Ganesh Krishnan Nov 15 '17 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.