10

Just upgrade from Ubuntu 17.04 to 17.10 in VirtualBox 5.1.26, very slow. It is unusable. It is running 4G RAM for Ubuntu 17.10. Any idea?

1
  • 1
    What does top say?
    – user535733
    Commented Oct 21, 2017 at 2:04

4 Answers 4

10

I had the same issue (8GB ram, 4 cpu's). The gnome-shell process constantly uses 10% cpu.

Disabling 3d acceleration did fix it (I didn't have 2D enabled as Virtualbox complains about it). Before you disable 3d acceleration be sure to disable the Virtualbox graphics driver under "Additional Hardware" inside of Unity. If you don't do that gdm3 won't even load.

The Unity desktop is still available and works fine, but one of the reasons to upgrade is to use Gnome. Even logging into unity and doing Additional drivers didn't help gnome.

4
  • With 17.04 I could even watch youtube videos in HD fine. Now in 17.10 everything lags. I don't know why though
    – GorillaApe
    Commented Oct 27, 2017 at 16:54
  • Hopefully this is just a bug and will get worked out. For now not having 3D acceleration works for me, but it was even worse before
    – ymmyk
    Commented Oct 27, 2017 at 22:00
  • Works but anything graphics related lags and freezes whole machine
    – GorillaApe
    Commented Oct 29, 2017 at 8:23
  • Yeah, but before this resizing a window caused the whole machine to crash, so it is at least better than that.
    – ymmyk
    Commented Oct 30, 2017 at 16:06
6

I disabled 2d acceleration in virtual box. It seems fine now.

1
  • 2
    FWIW, both 2D and 3D acceleration needs to be disabled in VirtualBox - only disabling 2d acceleration didn't work for me.
    – Dexter
    Commented Oct 25, 2017 at 8:19
2

With or without 3D it was all laggy for me on VirtualBox 5.2.8, host Mac OS X High Sierra and guest Ubuntu 7.10.
Switched to Unity and lag is gone.

2
  • Thanks! This worked for me, but only after installing VirtualBox Guest ADditions as well.
    – jtpereyda
    Commented Mar 28, 2018 at 18:07
  • Ya thanks for this... switching to Unity fixed all my issues. I already had updated guest additions suspecting that might be the culprit; but gnome-shell was using 60%+ cpu.
    – nzifnab
    Commented May 14, 2018 at 17:37
1

It seems that the Wayland display server may be the source of this bug.

I already had 2D and 3D acceleration deselected and was still getting very slow performance from Ubuntu17.10.

Clicking the gear icon beside the "Sign In" button on the log in screen gives the choice of using the default display server (Wayland) or Xorg and when I chose Xorg the flickering and high cpu usage all disappeared without having to switch to Unity.

Apparently the forthcoming 18.04 LTS will revert to using Xorg by default

1
  • My only options were Xorg (already selected), or Unity, the Xorg one was causing massive lag and crashes every time I tried doing anything - resizing windows etc. And top showed 60%+ constant CPU usage by gnome. Selecting unity from this gear when logging in made all the problems go away, and gave me back all my wasted top space so that my apps didn't all have 4 toolbars worth of space being wasted on screen.
    – nzifnab
    Commented May 14, 2018 at 17:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .