43

Only GNOME extension and native icons are displayed. Other icons like Dropbox, shutter, enpass etc. do not appear in the top bar.

Am I missing something? I already tried using extensions that I used with GNOME before but nothing (Topicons Plus, Ubuntu appindicators etc.) seems to help.

Currently I'm using Ubuntu Xorg, but in Wayland I have the same issue.

67

I've encountered the same problem. I tried to remove the indicator-application-service completely, and see, the problem went away! I guess coming from 16.04 leaves some Unity-related stuff on my machine that is not only obsolete but prevents the AppIndicator extension from properly working.

What to do:

sudo apt remove indicator-application
  • 1
    Did not work in my case.... – Ben Winding Oct 26 '17 at 8:19
  • 2
    @TylerDurden have you enabled the AppIndicator Gnome Shell Extension? My way of doing it is similar to the solution described at askubuntu.com/a/967226/751074, but permanent – enolive Oct 26 '17 at 16:20
  • Yes that extension seems to have fixed it, but the icons aren't in the bottom left anymore. Any idea why they changed that? – Ben Winding Oct 28 '17 at 8:23
  • Because Ubuntu Appindicator moves these icons from bottom left to tray panel. – QkiZ Nov 4 '17 at 20:39
  • 7
    Worked for me, after restarting Gnome Shell --- press Alt + f2 and execute the command r. – Rasmus Apr 12 '18 at 7:53
30

I have the same problem with 17.10. At least the following command helps here to bring the icons back until the next reboot:

killall indicator-application-service

Edit: This workaround is running fine here without using any gnome-extension like "Topicon-plus" or "Kstatusnotifieritem/appindicator support".

  • Yes, in Ubuntu 17.10. Directly after upgrading from 17.04 to 17.10 the indicators were shown, but after rebooting Ubuntu not anymore. With this upper workarround i can bring them back until next reboot. – amDude1848 Oct 21 '17 at 19:52
  • 2
    Cool! Theoretically one can then auto-execute this command at startup and won't have to bother again. – pomsky Oct 21 '17 at 19:55
  • Yeah thanks for the solution. I had the same idea and I am going to do this. :-) – amDude1848 Oct 21 '17 at 19:57
  • Yes, i am use an extension called "Kstatusnotifieritem/appindicator support", but i am not sure if it works because of the extension. Got this tip from OMGUbuntu-Website. – amDude1848 Oct 21 '17 at 20:00
  • Let us continue this discussion in chat. – pomsky Oct 21 '17 at 20:01
5

As suggested here, try removing all obsolete indicators if any still present

indicator-application
indicator-appmenu
indicator-bluetooth
indicator-common
indicator-datetime
indicator-keyboard
indicator-messages
indicator-network
indicator-power
indicator-printers
indicator-session
indicator-sound
indicator-transfer
indicator-transfer-download-manager

Just execute this command in a terminal:

sudo apt purge indicator-application indicator-appmenu indicator-bluetooth indicator-common indicator-datetime indicator-keyboard indicator-messages indicator-network indicator-power indicator-printers indicator-session indicator-sound indicator-transfer indicator-transfer-download-manager
2

Another possible solution is delete Indicator-application autostart .desktop file. It's installed in

/etc/xdg/autostart/indicator-application.desktop

If you dont want to remove it and sometimes is using Unity 7. This made Indicator-application not start at login.

  • Thanks, it worked! I was trying so many things which didn't work. – Steve Sep 10 '18 at 17:48
1

Nothing from suggested works for Shutter app in Ubuntu 18.04 as libgtk2-appindicator-perl package has been removed from main repo. To enable the Shutter indicator in Ubuntu 18.04 install libappindicator-dev:

libappindicator-dev

and Gtk2::AppIndicator perl extension:

sudo cpan -i Gtk2::AppIndicator

Restart Shutter, its indicator should appear now in system tray.

  • 1
    The only suggestion that actually displayed the Shutter icon. – Mr. T Aug 18 '18 at 9:17
  • There's a PPA that brings back the AppIndicator for Shutter, and every other feature missing due to removed dependencies (even those that are no longer available in Ubuntu for a long time, like the feature to take a screenshot of a website): linuxuprising.com/2018/10/… – Logix Dec 4 '18 at 12:48
1

In all currently supported versions of Ubuntu open the terminal and type:

sudo apt install indicator-applet-complete 

Indicator-applet is an applet to display information from various applications consistently in the GNOME panel. This instance will load all indicators in a single panel applet.

0

Click the nine dots on your dock.

applications icon

At the search field write "tweak". You will see gnome tweak tools:

searching gnome tweak tools

If you don't have it installed you can click it and that will open software center. You can install it from there.

After, run tweaks and go to extensions.

appindicator on tweak tools

Just turn the appindicators on and you will have a working system tray where you can see the dropbox, telegram or other icons.

  • 2
    Added two screenshots and a better explanation. Didn't do it before because my system is in portuguese, but I think it's clear anyway. – lapisdecor Oct 22 '17 at 16:00
  • 1
    This solution works and does not need to uninstall anything. Just uses the "Ubuntu Tweak" tool. – Ferdinand Prantl Nov 14 '17 at 8:36
  • I meant "gnome-tweak-tool"; not "ubuntu-tweak", which I wrote in the comment above. – Ferdinand Prantl Nov 14 '17 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.