5

there is something strange in Ubuntu 17.10. When I do shutdown (or reboot) the system hangs on black empty screen with cursor only. It is not tty1, nor tty7. The only way to let system shutdown is to switch on tty7 manually. After switching in 1-2 sec system continue shutdown itself normally. The question is how to avoid such behaviour.

  • 1
    I am having the same issue i need to switch to tty7 or the system won't shutdown/reboot – Ominus Oct 24 '17 at 20:17
  • In my case same issue seemed to be fixed by video drivers reinstallation. Although maybe it's a coincidence and real reason was something else – alexisrozhkov Oct 25 '17 at 18:11
  • I have the same problem in 17.10. In my case too switching to tty7 or sending the shutdown command from a tty console is the only way to shutdown the machine. Any update? – gianni Nov 15 '17 at 17:11
2

I had similar symptoms. I could get a successful reboot only by removing quiet splash from the GRUB_CMDLINE_LINUX_DEFAULT= line in /etc/default/grub (and running sudo update-grub).

Not a real solution, but at least it avoids the hang.

  • I'd try this if I had "quiet splash". I have only "splash". I'll try to remove that too. – gianni Nov 15 '17 at 17:13
0

Awesome - Here is my fix.

I had tried everything (10-20 different fixes, and getting frustrated - tough to troubleshoot), but this worked.

And i will re-iterate it for others.

Reduce the timeout in /etc/systemd/system.conf:

Remove # from these lines to activate them, and change timings in these following lines (they were 90 seconds!):

DefaultTimeoutStartSec=5s

DefaultTimeoutStopSec=5s

In terminal

sudo -H gedit /etc/systemd/system.conf

Save, Exit (reload it to confirm the changes as i had some strange "Gedit Errors)

Then run:

sudo systemctl daemon-reload

Reboot now in 5-10 Seconds - Awesome !

Say Thanks, Mark

  • DO NOT repost your same answer to many questions at once. If questions all use the same answer and are similar enough, consider flagging the questions as duplicates of this one, rather than duplicating your answers. – Thomas Ward Oct 23 '17 at 0:33
  • Sorry, but it does not work in my case. Neither 90s before editing the file system.conf, nor after setting 5s. I wait for 120s in both cases. Nothing. Only manual switching to TTY7! – Александр Авраменко Oct 23 '17 at 20:30
  • Maybe someone knows how to setup systemd to do this (switch to tty7) on shutdown/reboot? – Александр Авраменко Oct 23 '17 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.