25

I've installed Ubuntu 17.10 on my laptop without any issue, but when I am using the system everything lags and is not fluid. The mouse glitches (I am using a physical mouse and a track-pad), like it jumps, and is not fluid.

It is the same thing with the windows when I drag them or simply open any apps. The same thing is happening when I open the application page of Gnome.

I did try to change from Wayland to Xorg from the lock screen and by doing this the mouse is now working without any issue but I still have some glitch and fluidity problem everywhere.

Is this a problem with my computer or Ubuntu has an issue of some sort with Gnome on some devices and what can I do to fix this?

My laptop is an Asus Q501LA. I don't have a dedicated graphics card.

7
  • 5
    You're not alone in this one. I've got the same problem since I updated to Ubuntu 17.10. I also tried Wayland as well as the Xorg session, but the mouse delay remains. The strange this is though, that it works fine at the beginning after a restart and then the mouse movement delay starts kicking in at a random moment, not turning back to normal after that. Do you experience the same?
    – Forage
    Oct 29 '17 at 13:51
  • @Forage Yeah something similar it's random. I mostly have window movement lag than mouse lag
    – vinid223
    Oct 29 '17 at 17:17
  • 2
    Same problem here with 17.10 Xorg-Session. Mouse ist working at the beginng and a few hours later the OS is getting slower and slower and sometimes unfortunatelly mouse-clicks are missed, even 2-3 times in a row.
    – amDude1848
    Nov 7 '17 at 20:11
  • Hi! I had the same problem in 17.10. Using Unity instead of default Gnome has solved the problem for me. See itsfoss.com/use-unity-ubuntu-17-10 for info about how to choose Unity at login. Nov 19 '17 at 16:55
  • @LuisRodero-Merino Thanks for the info but I am really not interested in using Unity.
    – vinid223
    Nov 19 '17 at 18:36
13

Unfortunately, I don't think this is a Wayland only issue. After I upgraded from 17.04, I've found lag/sluggish response with gnome-shell under both Wayland and Xorg. It does seem to be a little worse under Wayland.

In my case, after a reboot, all is good for a while, but things slowly degrade and after a few hours, switching between virtual desktops or moving windows gets slower and slower. When the lock screen kicks in, after hitting a key to bring up the password prompt, there is a definite lag i.e. on a couple of occasions 15 seconds before the lockscreen wallpaper is cleared and the password prompt appears.

This is on a high spec machine i.e. 12 core i7 3Ghz with 32 Gb memory. I'm using the default oss graphics drivers (I have a nvidia gforce card, but not using the nvidia driver as it is not compatible with wayland).

I did not have these problems with 17.04 and the gnome ubuntu remix.

I've now installed MATE and seeing if that works better as the gnome-shell gets sluggish enough to be almost unusable unless I reboot every few hours.

Using journalctl to look at the logs, I see a lot of gnome-shell related errors and warnings.

All pretty disappointing. I was also unlucky enough to run into the fwupd bug related to some Logitech keyboards, so had to change my keyboard to even get 17.10 to work!

7
  • 2
    I am in a similar situation. I have kept open top -d 120 and it shows gnome-shell always consuming 10% to 20% cpu. This is far more than would be reasonable.
    – Rick-777
    Nov 2 '17 at 10:53
  • I have installed the nvidia driver for my gforce card and am now running the Gnome xorg version (not the ubuntu flavoured version) and so far, I'm not seeing the lag problems anymore. Journalctl is still showing quite a few errors which need further investigation, but I'm not seeing all the gnome-shell errors I was getting witht he Ubuntu flavoured version.
    – Tim X
    Nov 3 '17 at 13:05
  • @TimX Yeah installing the Nvidia drivers help the lag, but not completely and on my laptop which doesn't have a dedicated graphics card I can't install any graphics driver. The lag is just awful
    – vinid223
    Nov 4 '17 at 22:54
  • 1
    @vinid223 After a few days running the Nvidia drivers with the Gnome xorg version I had no repetition of the lag issue. I should also note that I also removed all the packaged shell extensions (except those which the gnome and ubuntu desktop packages rely on) and installed the key extensions I wanted using the web extension directly from the gnome site. I've not seen the lag problems reproduced. I have now switched back to the ubuntu xorg version and so far, no lag problems either. Recommend removing as many of the extensions you can and see if that has any impact. I'll monitor my system for n
    – Tim X
    Nov 5 '17 at 23:45
  • In my case, adding the Nvidia driver, removing Ubuntu bundled gnome extensions in preference to direct install via chrome gnome extension and running under xorg rather than wayland has SIGNIFICANTLY improved the stability of my system and addressed the lag problem. I do seem to get an increased lag over time, but it has now gone to days of uptime rather than just hours.
    – Tim X
    Nov 9 '17 at 22:18
5

GNOME has a history of being incredibly laggy. I have experienced the problems you've described on Ubuntu 17.10 and could not find a fix. I would suggest either downgrading GNOME to version 3.24 or simply downgrading Ubuntu to version 17.04.

4
  • Thanks for that answer. I would have wish to get a solution to keep GNOME 3.26 without lags but I guess it is just not stable yet
    – vinid223
    Oct 23 '17 at 1:05
  • Similar issue here, I had to downgrade to 17.04 for the time being. The OS worked fine, but the machine went bonkers while playing games requiring my (laptop) CPU to go on turbo. I suspect these issues are really hard to troubleshoot - at least I couldn't find a solution myself after hours digging...
    – Mena
    Oct 23 '17 at 15:01
  • Same issue here. The screen freeze randomly, the mouse shows several lags and when I type sometimes freeze and then the text appears like thiiiiiiiiiiis Oct 25 '17 at 13:04
  • I tried askubuntu.com/questions/966651/… with success so far Oct 25 '17 at 13:11
3

I found after first mouse click on the login screen, my USB mouse cursor started lagging and behaving somewhat erratically. Trackpad input works normally.. I tried the above suggestions to no avail. On another forum I saw irqpoll kernel parameter as a possible fix. It worked for me - now mouse works fine under default Ubuntu, Unity and Xfce.

Edit /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash irqpoll"

( I normally say noquiet nosplash - I want to see the boot messages! )

Hardware:

  • McBook Pro,5
  • NVidia GeForce 9400M (nvidia 340 driver)
  • USB Mouse
2
  • 1
    thanks! This fixed my issue on UbuntuStudio 16.04 with xfce, so most GNOME solutions didn't apply. Can you describe what's the cause for this, and what this fix does? Mar 24 '18 at 13:56
  • This irqpoll option worked for me on Lubuntu 19.04 with the new QT/C++ desktop.
    – Volomike
    Apr 25 '19 at 3:33
1

I have gnome extensions installed and system monitor on.

This has caused my lagging. The only fix was to change the Refresh Time in system-monitor to 50.

1
  • That doesn't make any sense with my problem. I have a tons of lags without the system monitor. This is not really a solution
    – vinid223
    Dec 2 '17 at 16:16
-1

From this answer:

"Gnome/Wayland has mouse tracking issues (see https://bugzilla.gnome.org/show_bug.cgi?id=745032)."

Ubuntu 17.10 uses wayland by default. however, you can switch back to Xorg, without to install anything, all you need to do is:

  1. Log out from you current user.

  2. Under the password, near the "unlock" button, you will have something like a settings-icon.

  3. Click it, and choose the second option(the one says "xorg")

  4. And there you have it! the good old xorg session, with no more cursor lags!

"Switching to an Xorg session from the log in screen should solve it."

Also: Looks like GDM3 is using Wayland by default too. I also needed to disable Wayland in GDM by uncommenting the WaylandEnable=false in /etc/gdm3/custom.conf.

4
  • 3
    Thanks for the info but like I said in my question I've already switched from wayland to xorg
    – vinid223
    Oct 26 '17 at 1:55
  • 2
    My problem is that even after switching back to xorg, I still have lag issue, but I do not have the mouse issue anymore
    – vinid223
    Oct 26 '17 at 1:56
  • 1
    Plagiarism of this answer: askubuntu.com/a/966709/166291 Nov 1 '17 at 13:07
  • 1
    @CedricReichenbach: Even if this answer would properly cite its source (and thus not be plagiarism) we don't allow duplicate answers here since they provide no benefit. However in this case the answer tries to add something to the original source and is thus different. Jan 24 '18 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.