10

I have just updated from Ubuntu 17.04. Natural scrolling was not activated, so I turned it on in Settings -> Devices -> Mouse & Touch-pad. But still not working... What can I do?

3 Answers 3

12

I followed advice from answers to the queston How to enable natural scrolling with mouse in 17.04?. In my case removing xserver-xorg-input-synaptics and restarting did the trick:

sudo apt remove xserver-xorg-input-synaptics

1
  • 1
    In case you want to keep using the synaptics driver: synclient VertScrollDelta=-108 HorizScrollDelta=-108 worked for me.
    – user142
    Mar 5, 2018 at 7:48
3

I got it working on mine. Credits to @pilot6 and Antonio Kordic for getting me to the correct solution: mine works with edge scrolling.

And is has nothing to do with libinput. The gsetting the settings use seems to be wrong initially(!). This was it:

gsettings set org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled true

Even weirder: changing "edge scrolling" in settings->mouse now ALSO works. And turning "natural scrolling" off now also reverses the direction. I do not get why this now works but it works for me ;)

2
  • It tells me: "property 'libinput Scroll Method Enabled' doesn't exist, you need to specify its type and format" Oct 20, 2017 at 18:20
  • @MatiasHaeussler try the full edit I just did ;)
    – Rinzwind
    Oct 21, 2017 at 4:23
-1

Add on /usr/share/X11/xorg.conf.d/40-libinput.conf file the next line:

Section "InputClass" Identifier "libinput touchpad catchall" --> Option "Tapping" "true" MatchIsTouchpad "on" MatchDevicePath "/dev/input/event*" Driver "libinput" EndSection

This line without the arrow:

--> Option "Tapping" "true"

Next step should either reboot (did myself) or restart X server, it seems is working for me!!

5
  • Tapping should be something else than natural scrolling(?)
    – Rinzwind
    Oct 20, 2017 at 20:00
  • It should be Option "NaturalScrolling" "True". And it should be below Driver "libinput"
    – Pilot6
    Oct 20, 2017 at 21:34
  • After add tapping and reboot could enable and disable scrolling on configuration. yes, it works for me as I said!! Took from here askubuntu.com/questions/947779/… ... it is what it is!!! Oct 20, 2017 at 23:02
  • Sorry @Pilot6. That did work in 17.04 for me but now with wayland ... nope. I followed your instructions from the reply Israel Diaz posted but no scrolling for me :(
    – Rinzwind
    Oct 21, 2017 at 4:17
  • Well, that doesn't work with wayland because there is no X. Wayland should have other configs to pass parameters to libinput. I don't use wayland yet.
    – Pilot6
    Oct 22, 2017 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.