I have been trying to get output on a projector through the VGA port on my Laptop (Dell Latitude 5480, Ubuntu 16.04). I have only Intel HD Graphics and no dedicated GPU.

I am not able to get any output on the projector.

xrandr does not list VGA in the output:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080     60.01*+  59.93    48.01  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1368x768      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   640x360       60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Output of lspci | grep VGA:

00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)

Output of lshw -numeric -C display:

WARNING: you should run this program as super-user.
       description: VGA compatible controller
       product: Intel Corporation [8086:591B]
       vendor: Intel Corporation [8086]
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915_bpo latency=0
       resources: irq:129 memory:ee000000-eeffffff memory:d0000000-dfffffff ioport:f000(size=64)

Other things I have tried

  • I have used Intel's Graphics Update tool and updated, but not of any help.
  • I have disabled Secure Boot and ran sudo apt-get update and upgrade.
  • I have selected a unknown device to use Processor microcode firmware for Intel CPUs from intel-microcode(proprietary), in the Additional Drivers.

What can be done to fix this and get output on the projector? Please help me out.

I have taken lot of care to select this laptop with configuration(Ubuntu pre-installed) so that most hardware works properly with Ubuntu, but this VGA problem has been a great pain.

  • Should I try forcing one of the HDMI ports to send a display output, considering the case that the VGA port might actually be HDMI internally?
    – Yaksha
    Oct 22, 2017 at 17:31
  • Could someone give some suggestion on this? I'm in bad need for solution to this problem :(
    – Yaksha
    Oct 24, 2017 at 5:15

1 Answer 1


Okay, answering my own question, my guess that the VGA port was actually HDMI internally was correct. To clarify, the three HDMIs stand for

  • HDMI 1(or 2) -External HDMI port
  • HDMI 2(or 1) -USB C type display port(never tried this port for display though)
  • HDMI 3 -External VGA port

Once I guessed this, I had to force xrandr to display output through one of these, as plugging in of VGA was not automatically detected. I knew that my projector was 4:3. So I tried some resolutions of 4:3 aspect ratio, like (both commands were necessary at every resolution in my case - to add a custom resolution):

xrandr --addmode HDMI3 1400x1050
xrandr --output HDMI3 --mode 1400x1050

The highest 4:3 resolution was 1400x1050.

I got an output on the projector successfully with HDMI3! But the display was clipped. Then I realised that my Laptop screen was displaying at a different resolution(16:9), so the screens were not getting properly mirrored.

I manually changed the Laptop screen to 1400x1050 and then projected:

xrandr --output eDP1 --mode 1400x1050
xrandr --addmode HDMI3 1400x1050
xrandr --output HDMI3 --mode 1400x1050

Now, everything was good. After plugging out, I shifted the Laptop Screen back to default resolution:

xrandr --output eDP1 --auto

For further use, I put the first three commands into a .sh file, ran them when I connected and the last one on plugging out.

These are the questions that helped me with the initial guess. Many thanks!:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .