5

I've just installed xubuntu 17.10 and cannot change xfce4-terminal keyboard shortcuts. I tried enabling editable accelerators (according to http://docs.xfce.org/faq), running:

Appearance -> Settings -> Menus and Buttons -> Enable editable accelerators: Tick

but when I hover the mouse over any menu item and press any key combination, nothing happens; I can see all shortcuts are greyed out, indicating that they can't be changed. I closed/reopened xfce4-terminal, and also logged out/in from the xfce session, to no avail, still can't change the shortcuts.

Don't know what changed in xfce because I remember being able to do this in past versions. I'm running fresh xubuntu 17.10, so xfce is version 4.12.3 and xfce4-terminal is 0.8.6-0ubuntu1.

Would anybody know how to change them ?

EDIT: I've just discovered that they can be changed editing:

~/.config/xfce4/terminal/accels.scm

Remove the leading ; from the menu entry and edit the shortcut. xfce4-terminal has to be closed/reopened for the new shortcuts to take effect. Not sure if this is the standard way of doing it, but at least it works.

EDIT 2: Found a good explanation about it here

  • The ~/.config/xfce4/terminal/accels.scm file doesn't seem to have any effect for me (xfce4-terminal 0.8.3 on MXLinux 17) – bli Feb 28 '18 at 13:01
  • So place you findings as an answer. – Suncatcher Mar 9 '18 at 8:55
  • Thanks very much for documenting this. These shortcuts have definitely been a moving target over the years. I'm not sure where the accelerators went, but just as I got used to those they decided to keep us on our toes :P I remember when they used to be simple, menu-driven deal, but yeah, not the worst thing to have this direct in a config file. I'm about to throw it into ansible now so I don't forget. Cheers! – Christopher Kuttruff Jun 8 '18 at 23:18
  • Oh, also just want to note that this identical across *nixes I think. That config file mentioned in OP existed for me and I'm on FreeBSD 11.1, xfce 4.12, and 0.8.7.3 of xfce4-terminal. This worked like a charm for me. But yeah, be sure to exit ALL open xfce terminal windows after updating config – Christopher Kuttruff Jun 8 '18 at 23:22
  • 1
    @ChristopherKuttruff, I get the impression it's a generic GTK method for setting accelerators, even though the specific filename may differ. For instance, I see that quodlibet uses ~/.config/quodlibet/accels, geeqie uses ~/.config/geeqie/accels, Thunar uses ~/.config/Thunar/accels.scm. – Paulo Marcel Coelho Aragão Jun 9 '18 at 12:36
2

As the solution was present in the question and in comments (along with contradictory statements) I will post an answer to make it more clear.

As said under Xfce bug report #12861 — "editable accelerators no more working in xfce4-terminal after GTK+3 migration":

gtk3 does not support editable accelerators. Since xfce4-terminal is a gtk3 app, this feature isn't available anymore...

That affects all later Xubuntu versions, not just 17.10.

accelerators can be changed via ~/.config/xfce4/terminal/accels.scm

While editing that file, as the OP said in the question, you have to remove the lead (the ; part at the beginning of the line); example for Ctrl-C for copy and Ctrl-V for paste:

(gtk_accel_path "<Actions>/terminal-window/paste" "<Primary>v")
(gtk_accel_path "<Actions>/terminal-window/copy" "<Primary>c")
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.