Installed Ubuntu 17.10 today, menubar, launcher and the bar which indicates time/date/network connection status are missing.

I am using the secondary display and connecting the laptop to the secondary. Even without the secondary display, the top bar on the screen and launcher are missing. When secondary is enabled and laptop display is disabled,there is no menu bar, launcher and bar at the screen top are also missing.

In Ubuntu 17.04 if we disable built-in-display and enable secondary display it works fine. How can I fix it in Ubuntu 17.10?


I think its simpler than that. Just set "show on" to "All displays" in the Dock settings on Ubuntu 17.10:


  • 1
    Maybe I have a GNOME extension which disables it, but I don't have the Dock menu item in my settings. – Dan Dec 7 '17 at 9:23
  • 1
    Hey @Dan try this answer : askubuntu.com/questions/967590/… – fer0x Feb 16 '18 at 4:13
  • 9
    This is only for the "Dock", the top bar (which shows time/date) is still shown on only one display. Any ideas? – IanDess Mar 21 '18 at 23:48
  • 1
    confirmed this is still the way to achieve this in 18.04 LTS – Todd Dec 16 '18 at 3:57

You might try enabling the "multi-monitors-add-on".

Follow the directions given here: https://www.maketecheasier.com/extend-gnome-3-panel-dual-monitors/,

Reproduced Here for convenience:

git clone https://github.com/spin83/multi-monitors-add-on.git
cd multi-monitors-add-on
cp -r multi-monitors-add-on@spin83 ~/.local/share/gnome-shell/extensions

Relaunch Gnome Shell by typing "Alt+F2", then typing "r" and pressing enter

Make sure you have gnome-tweak-tool

sudo apt install gnome-tweak-tool

Then open "tweaks" (gnome-tweak-tool), click on the "extensions", and then enable "Multi monitors add-on"

NB this Also works for Ubuntu 18.04...

  • Isn't it "https:" instead of "git:"? – Leonardo Castro Nov 9 '17 at 20:49
  • It certainly is. I'm not sure how that happened. Edit: fixed – N.B. Nov 10 '17 at 22:05
  • just upgraded to ubuntu 18.04. followed above, but extension does not show in tweak tool? – Oliver Schönrock May 25 '18 at 11:22
  • 1
    Also works in combination with: github.com/deadalnix/pixel-saver – Oliver Schönrock May 25 '18 at 11:54
  • 1
    This works, well, sort of... App-indicators are missing, as well as the Wi-Fi, Volume, Battery, and Login/Logout/Shutdown dropdown menu. – Henrique Ferrolho Jul 27 '18 at 10:54

I have the same problem. So far I was able to enable the launcher on every screen. To do that you need to go to Settings -> Dock and pick "All displays" for "Show on" setting.

  • Exactly what I was looking for. Thanks!!! – Abhi Jul 12 '19 at 6:40

Install the Gnome Tweak Tool:

sudo apt install gnome-tweak-tool

Then launch it


Or get to it by searching for "tweak" in the "Show Applications" area.

Bottom left will be a "workspaces" tab where you can tweak your workspaces. I found what I was looking for there.

enter image description here

  • This doesn't show taskbar on all displays. – Shital Shah Oct 22 '19 at 1:08
  • that option is just in a different area. I always configure the taskbar to show on all displays as well. – Jordan Oct 25 '19 at 0:38

I am not entirely sure if what I will suggest is helpful for the very specific question, but I hope it is helpful to other users.

After upgrading some pcs from Ubuntu Gnome 17.04 to Ubuntu 17.10 with dual monitors, it occurred to me that the monitor order and the primary monitor gets changed from the first monitor to the second.

This configuration can be found in the new Ubuntu in Settings, Devices, Displays:

Ubuntu 17.10 Monitor settings

You can drag-drop to reorder the displays, and there is a small area below labelled 'Primary Display' which is not very obvious that is clickable.


Have you tried setting the secondary display as your main one? The top panel only shows on the main display by default in Gnome 3.

Unfortunately multi monitor support in Gnome 3 is not really polished in my opinion. Hopefully things will get better now that Ubuntu is using it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.