6

I have installed 17.10 on a Lenovo 14 flex with touch screen. Each time I touch the screen a keyboard pops up. I can find no way to disable this feature. I can not type using it, making this even more annoying. Any way to disable this? Thanks

  • A work-around is to use an Ubuntu community flavour (Kubuntu, Lubuntu, ... Xubuntu), which I think do not use this feature. At least Lubuntu does not use it. I have tested it in my Dell Latitude E7240 with a touchscreen (with standard Ubuntu and with Lubuntu). – sudodus Oct 20 '17 at 16:33
1

This is a known bug. Please mark yourself affected here: https://bugs.launchpad.net/gnome-desktop/+bug/1723857

It's been a problem since 2015: https://bugzilla.redhat.com/show_bug.cgi?id=1274956,https://bugzilla.gnome.org/show_bug.cgi?id=742246

Florian made some patches this year (https://bugzilla.gnome.org/show_bug.cgi?id=788188), but I don't know how to apply them. Hence my as-of-yet unanswered question: How do I apply a GNOME patch?

| improve this answer | |
-1

I posted this answer on the other linked questions, but as this was the first result in my Google I thought I'd post it here as well for others that end up here. I had this issue on my Lenovo Yoga 300 after upgrading from 17.04 to 17.10.

The solution was to open the Universal Access app and turn the Screen Keyboard option off (in the Typing section).

Counter-intuitively, the on-screen keyboard still pops up if I tap a text field on screen. However, it no longer pops up when I start typing on the hardware keyboard, or when I tap other things on screen.

I hope it's as simple a fix for others as well.

| improve this answer | |
  • I had tried turning off "screen Keyboard Option" with no effect whatsoever. Sounds like it's supposed to be a feature, not a bug. If so I'll stick with 16.04. It's annoying so I imagine it will get fixed. I also noticed that holding down a key does not repeat the key. The sound control is crude- Unity has that lovely way of controlling volume with the mouse wheel, and from the same spot you can access Rhythm box. The Ubuntu version of Gnome, at any rate, is not quite ready for prime time. – user32674 Oct 21 '17 at 3:52
  • I can confirm that it works like this: 'Counter-intuitively, the on-screen keyboard still pops up if I tap a text field on screen'. Unfortunately different programs behave differently. Files alias nautilus makes the on-screen keyboard pop up only when I tap a text field on screen. But Firefox brings the on-screen keyboard no matter what. – sudodus Oct 21 '17 at 4:34
  • I reported the bug at the link provided. – user32674 Oct 22 '17 at 4:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.