12

I have just upgraded from Ubuntu 17.04 (Gnome flavor) to Ubuntu 17.10. All appears to have gone well in the upgrade, but I find after logging into either a gnome (wayland) gnome on xorg, ubuntu (wayland) or ubuntu on xorg, I lose all keyboard input. The mouse works fine, but keyboard fails to work at all. If I then logout of the session and return to gdm, the keyboard no longer works and so I cannot login to another session as I cannot enter any password.

I installed MATE and that works fine. I can login and the keyboard works fine. I also have stumpwm installed and that appears to work fine. So the problem seems to be Gnome specific either 'standard' gnome or Ubuntu flavoured gnome. Note that it was gnome I was using previously.

One other 'odd' bit of behaviour is that the main account I was using seems to have an additional session issue - when I try to log into this account, the desktop screen flashes up and then I'm returned straight back to the GDM login screen. This may be related to the fact I use zsh rather than bash as my shell on that account. I also see the same issue with keyboard e.g. once I have tried to login to that account and am returned to the gdm screen, I can no longer enter anything using the keyboard. Mouse works fine.

keyboard and mouse are both USB. This would appear to be something specific to Gnome and not related to the X server (or wayland) as other environments (stumpwm and MATE) work fine.

I did notice one other minor 'oddity'. I tried to use the on-screen keyboard. At first this seemed to be working, but then I noticed that when I tried to enter an '@' symbol, I just got a '2'. Something seems to be screwed up with input methods, but I quickly get out of my depth in this area. My region is set to English (Australia) with English (US) and English as fallbacks.

My next step will be to create a completely new/fresh account and see if that has any issues (in case the problem is due to some old gnome setting in .local, .cache .gnome etc.

Where to start to diagnose this issue?

UPDATE: I tried using a different keyboard and that seems to have resolved one problem. I can now login to a new account without loosing keyboard input for gnome or ubuntu sessions (wayland or xorg). So for some reason, the Logitech gaming keyboard I was using is not compatible with new versions of gnome (but still works fine under MATE). The replacement keyboard is an Apple aluminium USB, which seems to be working fine so far (though I have to yet verify alt/hyper etc all map correctly).

I still cannot login to accounts which existed previously with gnome or ubuntu sessions. I can login using MATE. This would seem to indicate there is something incompatible in the gnome environment beetween the gnome setup from 17.04 and 17.10. Still trying to work out what that might be.

  • 1
    I experienced the exact same error on a fresh install of 17.10. One thing I have to add is that after connecting another keyboard, both keyboards suddenly worked. It's not a solution, but maybe you can try that as well? – nhaesler Oct 20 '17 at 16:32
  • I have tried unplogguing and plugging the keyboard back in without success. I'll see if I can lay my hands on a second keyboard and see if that helps. – Tim X Oct 20 '17 at 20:45
  • Different keyboard seems to have fixed part of the problem. See question update. Seems logitech gaming keyboard will not work with gnome session. – Tim X Oct 20 '17 at 23:46
  • I'm seeing the same issue with my Logitech G110 keyboard. Upgraded from Ubuntu Gnome 17.04. I can login, and strangely my keyboard volume wheel works, but typing letters does not. I don't have another keyboard to try. – Chris Bauer Oct 21 '17 at 6:16
  • Yep, mine is a g110 as well. Works fine with MATE and it would seem older versions of GNOME, but not the new version shipped with Ubuntu 17.10. I swapped with my Mac keyboard - ironically, the G110 is working fine connected to my Mac while my Mac aluminium keyborad is working with Ubuntu 17.10. Temporary fix - need to get a new keyboard I guess. – Tim X Oct 21 '17 at 6:30
9

That is creepy that someone edited my comment for me. I don't like that at all. Feel free to add your own, don't edit my comment.

Original comment: Removing the package fwupd fixed the issue for me. You can remove it with sudo apt remove fwupd

Bug report: https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1717340

  • How to remove fwupd ? – Shiv Singh Oct 21 '17 at 18:36
  • Provided you can access apt before a gnome session is launched, you should be able to use the keyboard etc. Easiest thing to do is probably to hit shift while booting to get into the grub shell and boot into admin mode and use apt-get to remove the package. Alternatively, If you have not tried logging into gnome yet and your keyboard is still working, you can probably switch to a new virtual console with F2+ctl+alt and login as you and do sudo apt-get remove – Tim X Oct 22 '17 at 3:19
  • same problem for me... but this doesn't work. – IndexOutOfBoundsException Oct 22 '17 at 8:52
  • It should not be necessary to use the 'character' program or to install a virtual keyboard. There should already be a virtual keyboard installed as part of the accessibility options. You can select this using the accessiblity tab in the settings dialog. However, I did find that as I had a 'special' charactger in my password, the virtual keyboard option did not work as I couldn't enter that charactger. What I did was reboot and before trying to login, hit ctl+alt+f2 to switch to a different virtual terminal, logged in as me and then just removed the package using apt-get. – Tim X Oct 22 '17 at 22:17
  • 1
    I was facing almost same kind of problem; instead of just unresponsive keyboard, I'd get non-functional trackpad and keyboard. But after removing the package fwupd, both keyboard and trackpad are working. – Manish Kumar Bisht Nov 19 '17 at 2:16

protected by Community Oct 22 '17 at 22:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.